On Wed, Sep 26, 2007 at 09:05:15PM -0700, Randy Dunlap wrote: > On Thu, 27 Sep 2007 11:24:40 +0900 Paul Mundt wrote: > > > > +/* static helper functions */ > > > +static s32 max_compare(s32 v1, s32 v2) > > > +{ > > > + if (v1 < v2) > > > + return v2; > > > + else > > > + return v1; > > > +} > > > + > > > +static s32 min_compare(s32 v1, s32 v2) > > > +{ > > > + if (v1 < v2) > > > + return v1; > > > + else > > > + return v2; > > > +} > > > + > > min()/max() instead? > > Other code wants function pointers to the min & max functions. > That's why they are here AFAICT. > > > > > +/* assumes qos_lock is held */ > > > +static void update_target(int i) > > > +{ > > 'target' might be a more meaningful variable name. > > Anything but 'i'. The 'i' is gone. Will post new patch later today. --mgross _______________________________________________ linux-pm mailing list linux-pm@xxxxxxxxxxxxxxxxxxxxxxxxxx https://lists.linux-foundation.org/mailman/listinfo/linux-pm