Hi Nicolas, Am 04.05.20 um 10:59 schrieb Nicolas Saenz Julienne: > Hi Stefan, thanks for the review! > > On Sat, 2020-05-02 at 11:05 +0200, Stefan Wahren wrote: >>> + if (version) >>> + goto exit; >>> + >>> + dev_addr = pdev->bus->number << 20 | PCI_SLOT(pdev->devfn) << 15 | >>> + PCI_FUNC(pdev->devfn) << 12; >>> + >>> + ret = rpi_firmware_property(fw, RPI_FIRMWARE_NOTIFY_XHCI_RESET, >>> + &dev_addr, sizeof(dev_addr)); >>> + /* Wait for vl805 to startup */ >>> + udelay(200); >> I know, it makes it harder to read but do we really want to wait >> unnecessarily if rpi_firmware_property failed? > Yes, I figured that it wouldn't hurt much at that faulty state, and you'll be > waiting some extra 5s further down the line in quirk_usb_handoff_xhci(). > > But if you feel it's more correct I'll be happy to change it. no, i don't insist on that. Best regards Stefan