On Tuesday, October 15, 2019 1:00:16 AM CEST Bjorn Helgaas wrote: > From: Bjorn Helgaas <bhelgaas@xxxxxxxxxx> > > 27e20603c54b ("PCI/MSI: Move D0 check into pci_msi_check_device()") > moved the power state check into pci_msi_check_device(), which was > subsequently renamed to pci_msi_supported(). This didn't change the > behavior, since both callers checked the power state. > > However, it doesn't fit the current "pci_msi_supported()" name, which > should return what the device is capable of, independent of the power > state. > > Move the power state check back into the callers for readability. No > functional change intended. > > Signed-off-by: Bjorn Helgaas <bhelgaas@xxxxxxxxxx> No issues found, so Reviewed-by: Rafael J. Wysocki <rafael.j.wysocki@xxxxxxxxx> > --- > drivers/pci/msi.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/drivers/pci/msi.c b/drivers/pci/msi.c > index 0884bedcfc7a..20e9c729617c 100644 > --- a/drivers/pci/msi.c > +++ b/drivers/pci/msi.c > @@ -861,7 +861,7 @@ static int pci_msi_supported(struct pci_dev *dev, int nvec) > if (!pci_msi_enable) > return 0; > > - if (!dev || dev->no_msi || dev->current_state != PCI_D0) > + if (!dev || dev->no_msi) > return 0; > > /* > @@ -972,7 +972,7 @@ static int __pci_enable_msix(struct pci_dev *dev, struct msix_entry *entries, > int nr_entries; > int i, j; > > - if (!pci_msi_supported(dev, nvec)) > + if (!pci_msi_supported(dev, nvec) || dev->current_state != PCI_D0) > return -EINVAL; > > nr_entries = pci_msix_vec_count(dev); > @@ -1058,7 +1058,7 @@ static int __pci_enable_msi_range(struct pci_dev *dev, int minvec, int maxvec, > int nvec; > int rc; > > - if (!pci_msi_supported(dev, minvec)) > + if (!pci_msi_supported(dev, minvec) || dev->current_state != PCI_D0) > return -EINVAL; > > /* Check whether driver already requested MSI-X IRQs */ >