I have split the last patch into the two patches as suggested. One to add the new parameter and another to rename them nicely. There is no longer depreciation of the old kernel parameters - they are simply dropped, as suggested. I would find it cleaner to just do a single patch without the depreciation, as both patches change the same things, doubling up on the number of patch lines. I can still do this if requested. Bjorn has fixed a trivial problem with the second patch in the series not applying cleanly due to changes since I first sent it. He said not to bother fixing it. Please let me know if there are any more issues to be addressed. Sorry I took longer than intended. Cold / flu. The code is not as thoroughly tested as my last revision but the changes are pretty simple and it still works as intended and compiles cleanly. I just hope I did not let a oopsie through. Nicholas Johnson (5): PCI: Consider alignment of hot-added bridges when distributing available resources PCI: Cleanup comments in setup-bus.c to meet kernel coding style guidelines PCI: Fix serious bug when sizing bridges with additional size PCI: modify kernel parameters to differentiate between MMIO and MMIO_PREF sizes PCI: Rename pci=hpiosize,hpmemsize,hpmemprefsize to be more readable .../admin-guide/kernel-parameters.txt | 7 +- drivers/pci/pci.c | 18 +- drivers/pci/setup-bus.c | 512 +++++++++--------- include/linux/pci.h | 3 +- 4 files changed, 287 insertions(+), 253 deletions(-) -- 2.20.1