This patch series aims to improve Synopsys DesignWare Root Complex driver code by: - removing unnecessary header files - enforcing variable naming coherency among similar functions - simplifing code readability of mask/unmask function operations - replacing bit rotation operation (1 << bit) by BIT(bit) No functional changes are intended. All patches are independent so they can be easily analyzed and accepted or discarded. This patches organization also allows to easily merge (squash) some patches, if desired. Signed-off-by: Gustavo Pimentel <gustavo.pimentel@xxxxxxxxxxxx> Cc: Lorenzo Pieralisi <lorenzo.pieralisi@xxxxxxx> Cc: Joao Pinto <jpinto@xxxxxxxxxxxx> Cc: Jingoo Han <jingoohan1@xxxxxxxxx> Gustavo Pimentel (8): PCI: dwc: Remove unnecessary header include (of_gpio.h) PCI: dwc: Remove unnecessary header include (signal.h) PCI: dwc: Rename variable name from data to d on dw_pci_bottom_mask/unmask() PCI: dwc: Rename variable name from data to d on dw_pci_setup_msi_msg() PCI: dwc: Rename variable name from data to d on dw_pci_msi_set_affinity() PCI: dwc: Rename variable name from data to d on dw_pcie_irq_domain_free() PCI: dwc: Improve code readability and simplifies mask/unmask operations PCI: dwc: Replace bit rotation operation (1 << bit) by BIT(bit) drivers/pci/controller/dwc/pcie-designware-host.c | 52 +++++++++++------------ drivers/pci/controller/dwc/pcie-designware-plat.c | 2 - drivers/pci/controller/dwc/pcie-designware.h | 2 +- 3 files changed, 27 insertions(+), 29 deletions(-) -- 2.7.4