On Wed, May 30, 2018 at 12:54:15PM -0500, Bjorn Helgaas wrote: > void aer_print_port_info(struct pci_dev *dev, struct aer_err_info *info) > { > - pci_info(dev, "AER: %s%s error received: id=%04x\n", > + u8 bus = info->id >> 8; > + u8 devfn = info->id & 0xff; > + > + pci_info(dev, "AER: %s%s error received: %04x:%02x:%02x.%d\n", > info->multi_error_valid ? "Multiple " : "", > - aer_error_severity_string[info->severity], info->id); > + aer_error_severity_string[info->severity], > + pci_domain_nr(dev->bus), bus, devfn >> 3, devfn & 0x7); I think PCI_SLOT(devfn), PCI_FUNC(devfn) is a bit more readable.