The function name is just too confusing, rename it, no functional change. Rename the function to rcar_pcie_alloc_and_parse_pci_resource_list() as it's matching failpath function is pci_free_resource_list() so the names align much better and the new name also describes what the function does much better. Signed-off-by: Marek Vasut <marek.vasut+renesas@xxxxxxxxx> Cc: Geert Uytterhoeven <geert+renesas@xxxxxxxxx> Cc: Phil Edworthy <phil.edworthy@xxxxxxxxxxx> Cc: Simon Horman <horms+renesas@xxxxxxxxxxxx> Cc: Wolfram Sang <wsa@xxxxxxxxxxxxx> Cc: linux-renesas-soc@xxxxxxxxxxxxxxx --- drivers/pci/host/pcie-rcar.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/pci/host/pcie-rcar.c b/drivers/pci/host/pcie-rcar.c index e403c5206b24..dbc80e457f95 100644 --- a/drivers/pci/host/pcie-rcar.c +++ b/drivers/pci/host/pcie-rcar.c @@ -1051,7 +1051,7 @@ static const struct of_device_id rcar_pcie_of_match[] = { {}, }; -static int rcar_pcie_parse_request_of_pci_ranges(struct rcar_pcie *pci) +static int rcar_pcie_alloc_and_parse_pci_resource_list(struct rcar_pcie *pci) { int err; struct device *dev = pci->dev; @@ -1108,7 +1108,7 @@ static int rcar_pcie_probe(struct platform_device *pdev) INIT_LIST_HEAD(&pcie->resources); - err = rcar_pcie_parse_request_of_pci_ranges(pcie); + err = rcar_pcie_alloc_and_parse_pci_resource_list(pcie); if (err) goto err_free_bridge; -- 2.16.2