[+cc exynos folks, since pcie_host_ops.readl_rc affects them] - Add local "dev" pointers to reduce repetition of things like "&pdev->dev". - Remove platform drvdata because it appears unused (we called platform_set_drvdata() but not platform_get_drvdata()). Nothing here should change the behavior of the drivers. Changes from v1: Split uninline of register accessors into a separate patch. Add Kishon's *unroll() fix (v1 broke exynos). --- Bjorn Helgaas (9): PCI: designware: Rename dw_pcie_valid_config() to dw_pcie_valid_device() PCI: designware: Simplify pcie_host_ops.readl_rc() and .writel_rc() interfaces PCI: designware: Swap order of dw_pcie_writel_rc() reg/val arguments PCI: designware: Export dw_pcie_readl_rc(), dw_pcie_writel_rc() PCI: designware: Uninline register accessors PCI: designware: Swap order of dw_pcie_writel_unroll() reg/val arguments PCI: designware-plat: Remove redundant dw_plat_pcie.mem_base PCI: designware-plat: Add local struct device pointers PCI: designware-plat: Remove unused platform data Kishon Vijay Abraham I (1): PCI: designware: Simplify dw_pcie_readl_unroll(), dw_pcie_writel_unroll() drivers/pci/host/pci-exynos.c | 10 +-- drivers/pci/host/pcie-designware-plat.c | 25 +++----- drivers/pci/host/pcie-designware.c | 102 +++++++++++++++---------------- drivers/pci/host/pcie-designware.h | 7 +- 4 files changed, 67 insertions(+), 77 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html