On Fri, Oct 07, 2016 at 11:24:46AM -0500, Bjorn Helgaas wrote: > Rename rcar_pci_read_reg() to rcar_readl() and rcar_pci_write_reg() to > rcar_writel() for consistency with other drivers. No functional change > intended. > > Signed-off-by: Bjorn Helgaas <bhelgaas@xxxxxxxxxx> I am fine with this entire series. Acked-by: Simon Horman <horms+renesas@xxxxxxxxxxxx> > --- > drivers/pci/host/pcie-rcar.c | 142 ++++++++++++++++++++---------------------- > 1 file changed, 68 insertions(+), 74 deletions(-) > > diff --git a/drivers/pci/host/pcie-rcar.c b/drivers/pci/host/pcie-rcar.c > index e06b1d3..b6899c8 100644 > --- a/drivers/pci/host/pcie-rcar.c > +++ b/drivers/pci/host/pcie-rcar.c > @@ -152,16 +152,15 @@ struct rcar_pcie { > struct rcar_msi msi; > }; > > -static void rcar_pci_write_reg(struct rcar_pcie *pcie, unsigned long val, > - unsigned long reg) > +static unsigned long rcar_readl(struct rcar_pcie *pcie, unsigned long reg) > { > - writel(val, pcie->base + reg); > + return readl(pcie->base + reg); > } > > -static unsigned long rcar_pci_read_reg(struct rcar_pcie *pcie, > - unsigned long reg) > +static void rcar_writel(struct rcar_pcie *pcie, unsigned long val, > + unsigned long reg) > { > - return readl(pcie->base + reg); > + writel(val, pcie->base + reg); > } The diff might have been a bit easier on the eyes if rcar_pci_write_reg() was after rcar_pci_read_reg() -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html