This is mostly Mayurkumar's work from [1] and [2]. I split [2] into two patches and reworked it to keep the enclosing loop around the pciehp ISR. The patches I added are trivial ones to clarify variable names, make dmesg messages consistent, and remove useless code. [1] 1471554479-42083-1-git-send-email-mayurkumar.patel@xxxxxxxxx [2] 92EBB4272BF81E4089A7126EC1E7B28466598F35@xxxxxxxxxxxxxxxxxxxxxxxxxxxx --- Bjorn Helgaas (5): PCI: pciehp: Rename pcie_isr() locals for clarity PCI: pciehp: Return IRQ_NONE when we can't read interrupt status PCI: pciehp: Remove unnecessary guard PCI: pciehp: Clean up dmesg "Slot(%s)" messages PCI: pciehp: Remove useless pciehp_get_latch_status() calls Mayurkumar Patel (3): PCI: pciehp: Process all hotplug events before looking for new ones PCI: pciehp: Don't re-read Slot Status when queuing hotplug event PCI: pciehp: Don't re-read Slot Status when handling surprise event drivers/pci/hotplug/pciehp_ctrl.c | 83 ++++++++++++--------------------- drivers/pci/hotplug/pciehp_hpc.c | 94 ++++++++++++++++++++----------------- 2 files changed, 82 insertions(+), 95 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html