Hi Wolfram, On 07 November 2015 13:29, Wolfram wrote: > On Mon, Nov 02, 2015 at 04:36:13PM +0000, Phil Edworthy wrote: > > The main purpose of this change is to avoid calling pci_ioremap_io() as > > this is not available on arm64. However, instead of doing the range passing > > in this driver we can utilise of_pci_get_host_bridge_resources(). > > > > This is similar to changes made to the generic PCI host driver in commit > > dbf9826d "PCI: generic: Convert to DT resource parsing API". > > > > Signed-off-by: Phil Edworthy <phil.edworthy@xxxxxxxxxxx> > > Reported-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx> > Tested-by: Wolfram Sang <wsa+renesas@xxxxxxxxxxxxxxxxxxxx> > > Works for me and my USB3 card. I also like going the global io_offset > variable away and the code readability improved, too, IMO. > > One question: > > > > + case IORESOURCE_MEM: > > + parent = &iomem_resource; > > + res_valid |= !(res->flags & IORESOURCE_PREFETCH); > > + break; > > res_valid doesn't seem to be actually used? Ah, you are right. I'll remove this & send a v2 Thanks Phil -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html