These patches don't *do* anything except get rid of some overly verbose debug logging and a bunch of boilerplate code by inlining trivial things. Unless I made a mistake, this should not change the way anything works at all, although I did change some of the message text. --- Bjorn Helgaas (4): PCI: pciehp: Clean up debug logging PCI: pciehp: Make queue_interrupt_event() void PCI: pciehp: Rename queue_interrupt_event() to pciehp_queue_interrupt_event() PCI: pciehp: Inline the "handle event" functions into the ISR drivers/pci/hotplug/pciehp.h | 6 - drivers/pci/hotplug/pciehp_core.c | 37 +-------- drivers/pci/hotplug/pciehp_ctrl.c | 154 +++---------------------------------- drivers/pci/hotplug/pciehp_hpc.c | 89 +++++++++------------ 4 files changed, 53 insertions(+), 233 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html