On 2015/3/13 5:23, Bjorn Helgaas wrote: > On Mon, Mar 09, 2015 at 10:33:57AM +0800, Yijing Wang wrote: >> ... >> Yijing Wang (29): >> PCI: Rip out pci_bus_add_devices() from pci_scan_bus() >> PCI: Rip out pci_bus_add_devices() from pci_scan_root_bus() >> sparc/PCI: Claim bus resources before pci_bus_add_devices() > > I put the above patches plus a cleanup patch on my pci/enumeration branch. > Please rebase your next revision to that. If there's anything else > non-controversial that we can pull in to chip away at this, let me know. > Nice, so we could rebase the rest series easier, thanks! >> PCI: Export busn_resource to drivers/pci >> PCI: Remove deprecated pci_scan_bus_parented() >> PCI: Combine PCI domain and bus number in u32 arg >> PCI: Pass PCI domain number combined with root bus number >> PCI: Introduce pci_host_assign_domain_nr() to assign domain >> PCI: Separate pci_host_bridge creation out of pci_create_root_bus() >> PCI: Introduce pci_host_bridge_list to manage host bridges >> PCI: Save sysdata in pci_host_bridge drvdata >> PCI: Introduce pci_host_bridge_ops to support host specific >> operations >> PCI: Introduce new scan function pci_scan_host_bridge() >> x86/PCI: Refine pci_acpi_scan_root() with generic pci_host_bridge >> ia64/PCI: Refine pci_acpi_scan_root() with generic pci_host_bridge >> powerpc/pci: Rename pcibios_root_bridge_prepare() >> powerpc/pci: Use pci_scan_host_bridge() for simplicity >> PCI: Remove weak pcibios_root_bridge_prepare() >> sparc/PCI: Use pci_scan_host_bridge() for simplicity >> PCI: Introduce pci_bus_child_max_busnr() >> parisc/PCI: Use pci_scan_root_bus() for simplicity >> PCI/mvebu: Use pci_common_init_dev() to simplify code >> PCI/tegra: Remove redundant tegra_pcie_scan_bus() >> PCI/designware: Use pci_scan_root_bus() for simplicity >> PCI/xgene: Use pci_scan_root_bus() instead of pci_create_root_bus() >> PCI: Rename __pci_create_root_bus() to pci_create_root_bus() >> PCI: Export find_pci_host_bridge() and rename to >> pci_find_host_bridge() >> PCI: Remove platform specific pci_domain_nr() >> PCI: Remove pci_bus_assign_domain_nr() > > . > -- Thanks! Yijing -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html