Re: [PATCH] PCI: Add defines for max read requests sizes

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 26 January 2015 at 17:01, Bjorn Helgaas <bhelgaas@xxxxxxxxxx> wrote:
> On Mon, Jan 26, 2015 at 3:19 AM, Rafał Miłecki <zajec5@xxxxxxxxx> wrote:
>> There are few drivers using magic numbers when operating with PCIe
>> capabilities and PCI_EXP_DEVCTL_READRQ. Define known values to allow
>> cleaning their code a bit.
>>
>> Signed-off-by: Rafał Miłecki <zajec5@xxxxxxxxx>
>> ---
>> Hi,
>>
>> I'm new to the PCI subsystem, so let me know if there is anything wrong with my
>> patch. I hope you find these bits worth defining and that my coding style
>> matches rest of the file.
>> ---
>>  include/uapi/linux/pci_regs.h | 4 ++++
>>  1 file changed, 4 insertions(+)
>>
>> diff --git a/include/uapi/linux/pci_regs.h b/include/uapi/linux/pci_regs.h
>> index 4a1d0cc..efe3443 100644
>> --- a/include/uapi/linux/pci_regs.h
>> +++ b/include/uapi/linux/pci_regs.h
>> @@ -451,6 +451,10 @@
>>  #define  PCI_EXP_DEVCTL_AUX_PME        0x0400  /* Auxiliary Power PM Enable */
>>  #define  PCI_EXP_DEVCTL_NOSNOOP_EN 0x0800  /* Enable No Snoop */
>>  #define  PCI_EXP_DEVCTL_READRQ 0x7000  /* Max_Read_Request_Size */
>> +#define  PCI_EXP_DEVCTL_READRQ_128B  0x0000 /* 128 Bytes */
>> +#define  PCI_EXP_DEVCTL_READRQ_256B  0x1000 /* 256 Bytes */
>> +#define  PCI_EXP_DEVCTL_READRQ_512B  0x2000 /* 512 Bytes */
>> +#define  PCI_EXP_DEVCTL_READRQ_1024B 0x3000 /* 1024 Bytes */
>>  #define  PCI_EXP_DEVCTL_BCR_FLR 0x8000  /* Bridge Configuration Retry / FLR */
>>  #define PCI_EXP_DEVSTA         10      /* Device Status */
>>  #define  PCI_EXP_DEVSTA_CED    0x0001  /* Correctable Error Detected */
>
> This seems reasonable.  Can you include patches for the drivers to
> actually use these new symbols?  It's ideal if we can do them at the
> same time because we try to avoid adding new symbols unless they're
> going to actually be used.

Sure, but how to send them? Could the go through your (PCI) tree?

-- 
Rafał
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux