On Wed, Oct 08, 2014 at 09:44:05AM +0200, Thierry Reding wrote: > On Tue, Oct 07, 2014 at 03:57:58PM +0530, Vidya Sagar wrote: [...] > > +static inline void rp_writel(struct tegra_pcie_port *port, u32 value, > > + unsigned long offset) > > +{ > > + writel(value, offset + port->base); > > +} > > + > > +static inline unsigned int rp_readl(struct tegra_pcie_port *port, > > readl() returns u32 and so should rp_readl(). > > > + unsigned long offset) > > +{ > > + return readl(offset + port->base); > > +} > > I don't see much use in these, but if you really want to add them, > please also replace any of the open-coded occurrences of this. Also > please fix the alignment of function arguments on subsequent lines. > They should align with the first argument on the first line. Oh, and perhaps make it a separate (precursory) patch so that this patch can focus on the PM features. Thierry
Attachment:
pgp9QDnGBDssa.pgp
Description: PGP signature