On Wed, Jul 16, 2014 at 04:20:24PM -0600, Bjorn Helgaas wrote: > > @@ -809,22 +799,23 @@ out_free: > > } > > > > /** > > - * pci_msi_check_device - check whether MSI may be enabled on a device > > + * msi_check_device - check whether MSI may be enabled on a device > > * @dev: pointer to the pci_dev data structure of MSI device function > > * @nvec: how many MSIs have been requested ? > > - * @type: are we checking for MSI or MSI-X ? > > * > > * Look at global flags, the device itself, and its parent buses > > * to determine if MSI/-X are supported for the device. If MSI/-X is > > * supported return 0, else return an error code. > > **/ > > -static int pci_msi_check_device(struct pci_dev *dev, int nvec, int type) > > +static int msi_check_device(struct pci_dev *dev, int nvec) > > I think "check_device" is a terrible name because it really doesn't > give a clue about what it's doing or what the return value means. > Since you're removing the external usage (arch_msi_check_device) and > this one is static, this would be a good time to fix it. Maybe > "pci_msi_supported()" or something? What about pci_can_enable_msi() or pci_msi_can_enable() or msi_can_enable()? > I *love* the idea of getting rid of this much code! > > Bjorn -- Regards, Alexander Gordeev agordeev@xxxxxxxxxx -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html