Hello.
On 06/28/2014 04:15 AM, Simon Horman wrote:
This patch just makes symbol and function name changes to avoid
potential conflicts, along with minor formatting changes.
The only other change is to replace an arg passed into a func
with a local variable.
Signed-off-by: Phil Edworthy <phil.edworthy@xxxxxxxxxxx>
---
drivers/pci/host/pcie-rcar.c | 131 ++++++++++++++++++++++---------------------
1 file changed, 67 insertions(+), 64 deletions(-)
diff --git a/drivers/pci/host/pcie-rcar.c b/drivers/pci/host/pcie-rcar.c
index 680a8cc..efdea07 100644
--- a/drivers/pci/host/pcie-rcar.c
+++ b/drivers/pci/host/pcie-rcar.c
[...]
@@ -318,14 +319,15 @@ static struct pci_ops rcar_pcie_ops = {
.write = rcar_pcie_write_conf,
};
-static void rcar_pcie_setup_window(int win, struct resource *res,
- struct rcar_pcie *pcie)
+static void rcar_pcie_setup_window(int win, struct rcar_pcie *pcie)
{
+ struct resource *res = &pcie->res[win];
+
The removal of the res parameter is not in keeping with the changelog.
Could you break it out into a separate patch?
Sorry, I see that it is mentioned in the changelog.
But could you split the patch all the same?
I agree. Generally, you should not mix several changes of a different
nature in one patch.
WBR, Sergei
--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html