On Tue, Jun 25, 2013 at 2:15 PM, Bjorn Helgaas <bhelgaas@xxxxxxxxxx> wrote: >> +static int __init check_unassigned_resources(struct pci_dev *dev, void *data) > > I'm not going to add a function named "check_*()" because the name gives no > clue about what the return value means. If it's a boolean function, the > name should be something like a question that has a yes/no answer. that prototype return int is required by pci_walk_bus(). drivers/pci/bus.c:void pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *) return 1, will return early from pci_walk_bus(). count_unassigned_resources() is not good name too, as we bail out early. find_unassigned_resources() is more weird, looks like it want to return resource Yinghai -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html