Re: [PATCH] PCI/X86: increase info->res_num before checking pci_use_crs return

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2013/5/28 12:35, Yinghai Lu wrote:
> On Mon, May 27, 2013 at 7:55 PM, Yijing Wang <wangyijing@xxxxxxxxxx> wrote:
>> I separate this patch from patchset "Add hostbridge resource release to
>> support root bus hotplug in IA64", because it's a Separate issue.
>>
>> We should increase info->res_num before we checking pci_use_crs return
>> when pci=nocrs set.
> 
> there is no function change or issue here.

Hi Yinghai,
   Thanks for review and comments!
Yes, this patch is no functional change. I just sent this patch for make code flow more clearly.
Because free_pci_root_info_res() will free all info->res and info->res_offset. So I think move info->res_num++
before pci_use_crs check is better, better readability.

> 
>>
>> Signed-off-by: Yijing Wang <wangyijing@xxxxxxxxxx>
>> Cc: Yinghai Lu <yinghai@xxxxxxxxxx>
>> Cc: Jiang Liu <liuj97@xxxxxxxxx>
>> Cc: "Rafael J. Wysocki" <rafael.j.wysocki@xxxxxxxxx>
>> Cc: Feng Tang <feng.tang@xxxxxxxxx>
>> ---
>>  arch/x86/pci/acpi.c |    7 ++-----
>>  1 files changed, 2 insertions(+), 5 deletions(-)
>>
>> diff --git a/arch/x86/pci/acpi.c b/arch/x86/pci/acpi.c
>> index 3e72425..662dfdf 100644
>> --- a/arch/x86/pci/acpi.c
>> +++ b/arch/x86/pci/acpi.c
>> @@ -324,14 +324,11 @@ setup_resource(struct acpi_resource *acpi_res, void *data)
>>         res->start = start;
>>         res->end = end;
>>         info->res_offset[info->res_num] = addr.translation_offset;
>> +       info->res_num++;
>>
>> -       if (!pci_use_crs) {
>> +       if (!pci_use_crs)
>>                 dev_printk(KERN_DEBUG, &info->bridge->dev,
>>                            "host bridge window %pR (ignored)\n", res);
>> -               return AE_OK;
>> -       }
>> -
>> -       info->res_num++;
>>
>>         return AE_OK;
>>  }
> 
> info->res_num is not used after probe_pci_root_info for pci_nocrs case.
> 
> Thanks
> 
> Yinghai
> --
> To unsubscribe from this list: send the line "unsubscribe linux-pci" in
> the body of a message to majordomo@xxxxxxxxxxxxxxx
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> 
> 


-- 
Thanks!
Yijing

--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux