PowerPC and Microblaze have nearly identical definations of struct pci_controller - this patch unifies them in asm-generic to reduce code duplication and to allow new architectures to reuse. This patchset follows and depends on "of/pci: Provide common support for PCI DT parsing" which provided common 'ranges' parsing code which uses an architecture defined struct pci_controller. This patch is currently in Jason Coopers mvebu-next/pcie branch. It is hoped this will pave the way for providing common implementations of commonly duplicated functions found across the architectures such as pcibios_alloc|free_controller and pcibios_setup_phb_resources type functions. Andrew Murray (3): powerpc: Move struct pci_controller to asm-generic microblaze: Use asm-generic version of pci_controller pci: Use common definations of INDIRECT_TYPE_* arch/microblaze/include/asm/pci-bridge.h | 70 +----------------------- arch/powerpc/include/asm/pci-bridge.h | 82 --------------------------- arch/powerpc/sysdev/fsl_pci.c | 16 +++--- arch/powerpc/sysdev/indirect_pci.c | 20 +++--- arch/powerpc/sysdev/ppc4xx_pci.c | 4 +- arch/powerpc/sysdev/xilinx_pci.c | 2 +- include/asm-generic/pci-bridge.h | 90 ++++++++++++++++++++++++++++++ 7 files changed, 112 insertions(+), 172 deletions(-) -- To unsubscribe from this list: send the line "unsubscribe linux-pci" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html