> -----Original Message----- > From: Krzysztof Wilczyński <kw@xxxxxxxxx> > Sent: 04 March 2025 21:05 > To: Manivannan Sadhasivam <manivannan.sadhasivam@xxxxxxxxxx> > Cc: Shradha Todi <shradha.t@xxxxxxxxxxx>; linux-kernel@xxxxxxxxxxxxxxx; linux-pci@xxxxxxxxxxxxxxx; linux-arm- > kernel@xxxxxxxxxxxxxxxxxxx; linux-perf-users@xxxxxxxxxxxxxxx; lpieralisi@xxxxxxxxxx; robh@xxxxxxxxxx; bhelgaas@xxxxxxxxxx; > jingoohan1@xxxxxxxxx; Jonathan.Cameron@xxxxxxxxxx; fan.ni@xxxxxxxxxxx; nifan.cxl@xxxxxxxxx; > a.manzanares@xxxxxxxxxxx; pankaj.dubey@xxxxxxxxxxx; cassel@xxxxxxxxxx; 18255117159@xxxxxxx; > xueshuai@xxxxxxxxxxxxxxxxx; renyu.zj@xxxxxxxxxxxxxxxxx; will@xxxxxxxxxx; mark.rutland@xxxxxxx > Subject: Re: [PATCH v7 4/5] Add debugfs based error injection support in DWC > > Hello, > > [....] > > > > + 29) Generates duplicate TLPs - duplicate_dllp > > > > + 30) Generates Nullified TLPs - nullified_tlp > > > > > > Would the above field called "duplicate_dllp" for duplicate TLPs be > > > a potential typo? Perhaps this should be called "duplicate_tlp"? > > > > > > > Looks like a typo. As per Synopsys documentation, there is only 'duplicate TLP' > > field. > > > > Good catch! > > Updated. Thank you! > Sorry, this was a typo. Krzysztof, we need another change for this typo. diff --git a/drivers/pci/controller/dwc/pcie-designware-debugfs.c b/drivers/pci/controller/dwc/pcie-designware-debugfs.c index 729ac14ff700..4d77db3ca6ae 100644 --- a/drivers/pci/controller/dwc/pcie-designware-debugfs.c +++ b/drivers/pci/controller/dwc/pcie-designware-debugfs.c @@ -113,7 +113,7 @@ static const struct dwc_pcie_err_inj err_inj_list[] = { {"posted_tlp_data", 0x4, 0x4}, {"non_post_tlp_data", 0x4, 0x5}, {"cmpl_tlp_data", 0x4, 0x6}, - {"duplicate_dllp", 0x5, 0x0}, + {"duplicate_tlp", 0x5, 0x0}, {"nullified_tlp", 0x5, 0x1}, }; So sorry for the inconvenience! Should I post a patch for this? > Krzysztof