On Mon, Feb 17, 2025 at 9:37 AM Danilo Krummrich <dakr@xxxxxxxxxx> wrote: > > On Mon, Feb 17, 2025 at 09:21:00AM -0500, Tamir Duberstein wrote: > > On Mon, Feb 17, 2025 at 9:15 AM Danilo Krummrich <dakr@xxxxxxxxxx> wrote: > > > > > > On Mon, Feb 17, 2025 at 09:02:12AM -0500, Tamir Duberstein wrote: > > > > > > diff --git a/rust/kernel/pci.rs b/rust/kernel/pci.rs > > > > > > index 6c3bc14b42ad..eb25fabbff9c 100644 > > > > > > --- a/rust/kernel/pci.rs > > > > > > +++ b/rust/kernel/pci.rs > > > > > > @@ -73,6 +73,7 @@ extern "C" fn probe_callback( > > > > > > match T::probe(&mut pdev, info) { > > > > > > Ok(data) => { > > > > > > let data = data.into_foreign(); > > > > > > + let data = data.cast(); > > > > > > > > > > Same here and below, see also [2]. > > > > > > > > You're the maintainer, > > > > > > This isn't true. I'm the original author, but I'm not an official maintainer of > > > this code. :) > > > > > > > so I'll do what you ask here as well. I did it > > > > this way because it avoids shadowing the git history with this change, > > > > which I thought was the dominant preference. > > > > > > As mentioned in [2], if you do it the other way around first the "rust: types: > > > add `ForeignOwnable::PointedTo`" patch and then the conversion to cast() it's > > > even cleaner and less code to change. > > > > This is true for the two instances of `as _`, > > Yes, those are the ones I talk about. > > > but not for all the > > other instances where currently there's no cast, but one is now > > needed. > > > > > > > > > > > I understand you like this style and I'm not saying it's wrong or forbidden and > > > > > for code that you maintain such nits are entirely up to you as far as I'm > > > > > concerned. > > > > > > > > > > But I also don't think there is a necessity to convert things to your preference > > > > > wherever you touch existing code. > > > > > > > > This isn't a conversion, it's a choice made specifically to avoid > > > > touching code that doesn't need to be touched (in this instance). > > > > > > See above. > > > > This doesn't address my point. I claim that > > > > @@ -246,6 +248,7 @@ impl<T: MiscDevice> VtableHelper<T> { > > ) -> c_int { > > // SAFETY: The release call of a file owns the private data. > > let private = unsafe { (*file).private_data }; > > + let private = private.cast(); > > // SAFETY: The release call of a file owns the private data. > > let ptr = unsafe { <T::Ptr as ForeignOwnable>::from_foreign(private) }; > > > > is a better diff than > > > > @@ -245,7 +245,7 @@ impl<T: MiscDevice> VtableHelper<T> { > > file: *mut bindings::file, > > ) -> c_int { > > // SAFETY: The release call of a file owns the private data. > > - let private = unsafe { (*file).private_data }; > > + let private = unsafe { (*file).private_data }.cast(); > > // SAFETY: The release call of a file owns the private data. > > let ptr = unsafe { <T::Ptr as ForeignOwnable>::from_foreign(private) }; > > > > because it doesn't acquire the git blame on the existing line. > > I disagree with the *rationale*, because it would also mean that if I have > > let result = a + b; > > and it turns out that we're off by one later on, it'd be reasonable to change it > to > > let result = a - b; > let result = result + 1; > > in order to not acquire the git blame of the existing line. Like anything, it depends. If something changes from being 0-indexed to 1-indexed then I'd say what you have there is perfectly reasonable: the 1-bias is logically separate from `a - b`. That's a fine analogy for what's happening in this patch. > > > > > > > > > > > I already explicitly asked you not to do so in [3] and yet you did so while > > > > > keeping my ACK. :( > > > > > > > > > > (Only saying the latter for reference, no need to send a new version of [3], > > > > > otherwise I would have replied.) > > > > > > > > > > [2] https://lore.kernel.org/rust-for-linux/Z7MYNQgo28sr_4RS@cassiopeiae/ > > > > > [3] https://lore.kernel.org/rust-for-linux/20250213-aligned-alloc-v7-1-d2a2d0be164b@xxxxxxxxx/ > > > > > > > > I will drop [2] and leave the `as _` casts in place to minimize > > > > controversy here. > > > > > > As mentioned I think the conversion to cast() is great, just do it after this > > > one and keep it a single line -- no controversy. :) > > > > The code compiles either way, so I'll leave it untouched rather than > > risk being scolded for sneaking unrelated changes. > > Again, I never did that, but as already mentioned if it came across this way, > please consider that I tell you now, that it wasn't meant to be. Wasn't my intention to imply that this was something you did. It was meant as a general observation. > You're free to do the change (I encourage that), but that's of course up to you. I'll create a "good first issue" for it in the RfL repository. > Subsequently, I kindly ask you though to abstain from saying that I accused you > of something or do scold you. Thanks! Certainly. I'll point out, as you did, that I never said that.