On Sat, Dec 21, 2024 at 01:19:45AM +0900, Krzysztof Wilczyński wrote: > > +config NVME_TARGET_PCI_EPF > > + tristate "NVMe PCI Endpoint Function target support" > > + depends on NVME_TARGET && PCI_ENDPOINT > > + help > > + This enables the NVMe PCI endpoint function target driver support, > > + which allows creating a NVMe PCI controller using an endpoint mode > > + capable PCI controller. > > + > > Perhaps: > > This enables the NVMe PCI Endpoint Function target support, which allows > for the creation of an NVMe PCI controller using an endpoint mode capable > PCI Express controller. I like your suggestion. However, looking at drivers/nvme/target/Kconfig: $ git grep "This enables" origin/master drivers/nvme origin/master:drivers/nvme/target/Kconfig: This enables debugfs support to display the connected controllers origin/master:drivers/nvme/target/Kconfig: This enables target side NVMe passthru controller support for the origin/master:drivers/nvme/target/Kconfig: This enables the NVMe loopback device support, which can be useful origin/master:drivers/nvme/target/Kconfig: This enables the NVMe RDMA target support, which allows exporting NVMe origin/master:drivers/nvme/target/Kconfig: This enables the NVMe FC target support, which allows exporting NVMe origin/master:drivers/nvme/target/Kconfig: This enables the NVMe FC loopback test support, which can be useful origin/master:drivers/nvme/target/Kconfig: This enables the NVMe TCP target support, which allows exporting NVMe origin/master:drivers/nvme/target/Kconfig: This enables support for NVMe over Fabrics In-band Authentication in It seems to use both: "This enables the NVMe ... support" "This enables NVMe ... support" In this case, I think it reads better if we use the latter. In fact, in all these cases I think it reads better without the "the". Perhaps add a clean up patch that drops the "the"? Kind regards, Niklas