On Tue, Nov 26, 2024 at 01:15:59PM -0600, Rob Herring wrote: > On Tue, Nov 26, 2024 at 9:17 AM Danilo Krummrich <dakr@xxxxxxxxxx> wrote: > > > > On Tue, Nov 26, 2024 at 08:44:19AM -0600, Rob Herring wrote: > > > > > > > The DT type and name fields are pretty much legacy, so I don't think the > > > > > > > rust bindings need to worry about them until someone converts Sparc and > > > > > > > PowerMac drivers to rust (i.e. never). > > > > > > > > > > > > > > I would guess the PCI cases might be questionable, too. Like DT, drivers > > > > > > > may be accessing the table fields, but that's not best practice. All the > > > > > > > match fields are stored in pci_dev, so why get them from the match > > > > > > > table? > > > > > > > > > > > > Fair question, I'd like to forward it to Greg. IIRC, he explicitly requested to > > > > > > make the corresponding struct pci_device_id available in probe() at Kangrejos. > > > > > > Making it available is not necessarily the same thing as passing it in > > > via probe. > > > > IIRC, that was exactly the request. > > > > > I agree it may need to be available in probe(), but that > > > can be an explicit call to get it. > > > > Sure, I did exactly that for the platform abstraction, because there we may > > probe through different ID tables. > > TBC, I think of_match_device() (both calling the C API and the method) > should not be part of this series. I think we agreed on that already. > Only if there is a need at some point later should we add it. That matches my understanding. > > > A `struct pci_driver`'s probe function has the following signature [1] though: > > > > `int (*probe)(struct pci_dev *dev, const struct pci_device_id *id)` > > > > [1] https://elixir.bootlin.com/linux/v6.12/source/include/linux/pci.h#L950 > > We have a mixture of probe with and without the _device_id parameter. > I'd question if we really want to keep that for PCI when we have a > chance to align things with Rust. We can't really with C as it would > be too many drivers to change. Passing the _device_id only works if > firmware matching is never used which can change over time. But if > aligning things is not something we want to do, then I'll shut up. I don't disagree. Again, this one is on Greg to comment on. Personally, I'm fine with both. > > > > > > Which table gets passed in though? Is the IdInfo parameter generic and > > > > > can be platform_device_id, of_device_id or acpi_device_id? Not sure if > > > > > that's possible in rust or not. > > > > > > > > Not sure I can follow you here. > > > > > > > > The `IdInfo` parameter is of a type given by the driver for driver specific data > > > > for a certain ID table entry. > > > > > > > > It's analogue to resolving `pci_device_id::driver_data` in C. > > > > > > As I said below, the PCI case is simpler than for platform devices. > > > Platform devices have 3 possible match tables. The *_device_id type we > > > end up with is determined at runtime (because matching is done at > > > runtime), so IdInfo could be any of those 3 types. > > > > `IdInfo` is *not* any of the three *_device_id types. It's the type of the > > drivers private data associated with an entry of any of the three ID tables. > > Ah yes, indeed. So no issue with the probe method. > > > It is true that a driver, which registers multiple out of those three tables is > > currently forced to have the same private data type for all of them. > > I think that's a feature actually as it enforces best practices. Agreed. > > > I don't think this is a concern, is it? If so, it's easily resolvable by just > > adding two more associated types, e.g. `PlatformIdInfo`, `DtIdInfo` and > > `AcpiIdInfo`. > > > > In this case we would indeed need accessor functions like `dt_match_data`, > > `platform_match_data`, `acpi_match_data`, since we don't know the type at > > compile time anymore. > > Do we need to split those out in rust or can we just call > device_get_match_data()? We'd need to split them, because they potentially would return different types. (Again, I don't think that's necessary though.) For C it's just a void pointer, so we don't bother there, but in Rust we'd want it type safe. > > > > > I don't think that's necessary though. > > Even if you don't support all 3 tables now, at a minimum I think you > need to rename things to be clear what table type is supported and > allow for adding the other types. For example, T::ID_TABLE needs to be > renamed to be clear it's the of_device_id table. Sure, I already got this on my list of changes for the next version. > > Rob >