On Thu, 2024-10-31 at 14:45 +0100, Thomas Gleixner wrote: > On Tue, Oct 15 2024 at 20:51, Philipp Stanner wrote: > > +/** > > + * pci_intx - enables/disables PCI INTx for device dev, unmanaged > > version > > mismatch vs. actual function name. ACK, will fix > > > + * @pdev: the PCI device to operate on > > + * @enable: boolean: whether to enable or disable PCI INTx > > + * > > + * Enables/disables PCI INTx for device @pdev > > + * > > + * This function behavios identically to pci_intx(), but is never > > managed with > > + * devres. > > + */ > > +void pci_intx_unmanaged(struct pci_dev *pdev, int enable) > > This is a misnomer. The function controls the INTX_DISABLE bit of a > PCI device. Something like this: > > void __pci_intx_control() > { > } > > static inline void pci_intx_enable(d) > { > __pci_intx_control(d, true); > } > > ..... > > makes it entirely clear what this is about. Well, I would agree if it were about writing a 'real' new function. But this is actually about creating a _temporary_ function which is added here and removed again in patch 12 of this same series. It wouldn't even be needed; the only reason why it exists is to make it easy for the driver maintainers concerned by patches 2-11 to review the change and understand what's going on. Hence it is "pci_intx_unmanaged()" == "Attention, we take automatic management away from your driver" pci_intx() is then fully restored after patch 12 and it keeps its old name. Grüße, Philipp > > Hmm? > > Thanks, > > tglx >