Re: [PATCH 1/2] PCI: endpoint: Introduce 'get_bar' to map fixed address BARs in EPC

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 7/25/24 14:33, Manivannan Sadhasivam wrote:
> On Tue, Jul 23, 2024 at 06:48:27PM +0200, Niklas Cassel wrote:
>> Hello Rick,
>>
>> On Tue, Jul 23, 2024 at 06:06:26PM +0200, Rick Wertenbroek wrote:
>>>>
>>>> But like you suggested in the other mail, the right thing is to merge
>>>> alloc_space() and set_bar() anyway. (Basically instead of where EPF drivers
>>>> currently call set_bar(), the should call alloc_and_set_bar() (or whatever)
>>>> instead.)
>>>>
>>>
>>> Yes, if we merge both, the code will need to be in the EPC code
>>> (because of the set_bar), and then the pci_epf_alloc_space (if needed)
>>> would be called internally in the EPC code and not in the endpoint
>>> function code.
>>>
>>> The only downside, as I said in my other mail, is the very niche case
>>> where the contents of a BAR should be moved and remain unchanged when
>>> rebinding a given endpoint function from one controller to another.
>>> But this is not expected in any endpoint function currently, and with
>>> the new changes, the endpoint could simply copy the BAR contents to a
>>> local buffer and then set the contents in the BAR of the new
>>> controller.
>>> Anyways, probably no one is moving live functions between controllers,
>>> and if needed it still can be done, so no problem here...
>>
>> I think we need to wait for Mani's opinion, but I've never heard of anyone
>> doing so, and I agree with your suggested feature to copy the BAR contents
>> in case anyone actually changes the backing EPC controller to an EPF.
>> (You would need to stop the EPC to unbind + bind anyway, IIRC.)
>>
> 
> Hi Rick/Niklas,
> 
> TBH, I don't think currently we have an usecase for remapping the EPC to EPF. So
> we do not need to worry until the actual requirement comes.
> 
> But I really like combining alloc() and set_bar() APIs. Something I wanted to do
> for so long but never got around to it. We can use the API name something like
> pci_epc_alloc_set_bar(). I don't like 'set' in the name, but I guess we need to
> have it to align with existing APIs.
> 
> And regarding the implementation, the use of fixed address for BAR is not new.
> If you look into the pci-epf-mhi.c driver, you can see that I use a fixed BAR0
> location that is derived from the controller DT node (MMIO region).
> 
> But I was thinking of moving this region to EPF node once we add DT support for
> EPF driver. Because, there can be many EPFs in a single endpoint and each can
> have upto 6 BARs. We cannot really describe each resource in the controller DT
> node.
> 
> Given that you really have a usecase now for multiple BARs, I think it is best
> if we can add DT support for the EPF drivers and describe the BAR resources in
> each EPF node. With that, we can hide all the resource allocation within the EPC
> core without exposing any flag to the EPF drivers.
> 
> So if the EPF node has a fixed location for BAR and defined in DT, then the new
> API pci_epf_alloc_set_bar() API will use that address and configure it
> accordingly. If not, it will just call pci_epf_alloc_space() internally to
> allocate the memory from coherent region and use it.

EPF node ? Did you perhaps mean EPC node ?
Using DT for endpoint functions is nonsense in my opinion: if something needs to
be configured, an epf has the configfs interface to get the information it may
need. And forcing EPF to have DT node is not scalable anyway.

So assuming you meant EPC, I am not sure if defining a fixed bar address in the
DT works for all cases. E.g. said address may depend on other hardware on the
platform (ex: memory nodes). So the ->get_bar() EPC operation that Rick is
proposing makes a lot more sense to me and will can be scaled to many many
configurations. Given that the EPF will (indirectly) call that operation, some
epf dependent parameters could even be passed.

And I agree (I think we all do) that combing alloc bar and get bar under a
single API is a lot cleaner. Though I am not a big fan of the name
pci_epc_alloc_set_bar() as it implies an allocation, which may not be the case
for fixed bars. So a simpler and more generic name like pci_epf_set_bar(),
pci_epf_init_bar(), pci_epf_config_bar()... would be way better in my opinion.


-- 
Damien Le Moal
Western Digital Research





[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux