Re: [PATCH] PCI: hv: fix reading of PCI_INTERRUPT_LINE and PCI_INTERRUPT_PIN

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, Jun 21, 2024 at 06:19:05AM +0000, Wei Liu wrote:
> On Fri, Jun 21, 2024 at 03:15:19AM +0000, Michael Kelley wrote:
> > From: Wei Liu <wei.liu@xxxxxxxxxx> Sent: Thursday, June 20, 2024 6:48 PM
> > > 
> > > The intent of the code snippet is to always return 0 for both fields.
> > > The check is wrong though. Fix that.
> > > 
> > > This is discovered by this call in VFIO:
> > > 
> > >     pci_read_config_byte(vdev->pdev, PCI_INTERRUPT_PIN, &pin);
> > > 
> > > The old code does not set *val to 0 because the second half of the check is
> > > incorrect.
> > > 
> > > Fixes: 4daace0d8ce85 ("PCI: hv: Add paravirtual PCI front-end for Microsoft Hyper-V
> > > VMs")

12 characters are preferred for Fixes commit id.
'Fixes: 4daace0d8ce8 ("PCI: hv: Add paravirtual PCI front-end for Microsoft Hyper-V VMs")'

> > > Cc: stable@xxxxxxxxxx
> > > Signed-off-by: Wei Liu <wei.liu@xxxxxxxxxx>
> > > ---
> > >  drivers/pci/controller/pci-hyperv.c | 4 ++--
> > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > > 
> > > diff --git a/drivers/pci/controller/pci-hyperv.c b/drivers/pci/controller/pci-hyperv.c
> > > index 5992280e8110..eec087c8f670 100644
> > > --- a/drivers/pci/controller/pci-hyperv.c
> > > +++ b/drivers/pci/controller/pci-hyperv.c
> > > @@ -1130,8 +1130,8 @@ static void _hv_pcifront_read_config(struct hv_pci_dev
> > > *hpdev, int where,

<snip>


> I had a version that looked like this:
> 
> diff --git a/drivers/pci/controller/pci-hyperv.c b/drivers/pci/controller/pci-hyperv.c
> index 5992280e8110..cdd5be16021d 100644
> --- a/drivers/pci/controller/pci-hyperv.c
> +++ b/drivers/pci/controller/pci-hyperv.c
> @@ -1130,8 +1130,8 @@ static void _hv_pcifront_read_config(struct hv_pci_dev *hpdev, int where,
>                    PCI_CAPABILITY_LIST) {
>                 /* ROM BARs are unimplemented */
>                 *val = 0;
> -       } else if (where >= PCI_INTERRUPT_LINE && where + size <=
> -                  PCI_INTERRUPT_PIN) {
> +       } else if ((where >= PCI_INTERRUPT_LINE && where + size <= PCI_INTERRUPT_PIN) ||
> +                  (where >= PCI_INTERRUPT_PIN && where + size <= PCI_MIN_GNT)) {

IMHO, I prefer this one due to consistency. We can have these 2 condition as separate "else if"
as well, which would align better with the rest of the logic in this function. However, I don't
have a strong preference on this matter.

- Saurabh




[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux