Re: [PATCH v2 2/7] resource: Rename find_resource() to find_empty_resource_slot()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Dec 28, 2023 at 06:57:02PM +0200, Ilpo Järvinen wrote:
> Rename find_resource() to find_empty_resource_slot() to better describe
> what the functions does. This is a preparation for exposing it beyond
> resource.c which is needed by PCI core. Also rename the __ variant to
> match the names.

I wonder if "find_resource_space()" or "find_available_resource()"
would be better than "_slot"?

"Slot" *is* already used a few times in kernel/resource.c, but in most
cases I think it refers to a "resource", and find_resource() basically
returns a filled-in struct resource.

And of course "slot" suggests something entirely different in the PCI
context.

> Signed-off-by: Ilpo Järvinen <ilpo.jarvinen@xxxxxxxxxxxxxxx>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxxxxxxxx>
> ---
>  kernel/resource.c | 19 +++++++++----------
>  1 file changed, 9 insertions(+), 10 deletions(-)
> 
> diff --git a/kernel/resource.c b/kernel/resource.c
> index 866ef3663a0b..94f67005e1e2 100644
> --- a/kernel/resource.c
> +++ b/kernel/resource.c
> @@ -574,10 +574,9 @@ static void resource_clip(struct resource *res, resource_size_t min,
>   * Find empty slot in the resource tree with the given range and
>   * alignment constraints
>   */
> -static int __find_resource(struct resource *root, struct resource *old,
> -			 struct resource *new,
> -			 resource_size_t  size,
> -			 struct resource_constraint *constraint)
> +static int __find_empty_resource_slot(struct resource *root, struct resource *old,
> +				      struct resource *new, resource_size_t size,
> +				      struct resource_constraint *constraint)
>  {
>  	struct resource *this = root->child;
>  	struct resource tmp = *new, avail, alloc;
> @@ -633,11 +632,11 @@ next:		if (!this || this->end == root->end)
>  /*
>   * Find empty slot in the resource tree given range and alignment.
>   */
> -static int find_resource(struct resource *root, struct resource *new,
> -			resource_size_t size,
> -			struct resource_constraint  *constraint)
> +static int find_empty_resource_slot(struct resource *root, struct resource *new,
> +				    resource_size_t size,
> +				    struct resource_constraint *constraint)
>  {
> -	return  __find_resource(root, NULL, new, size, constraint);
> +	return  __find_empty_resource_slot(root, NULL, new, size, constraint);
>  }
>  
>  /**
> @@ -660,7 +659,7 @@ static int reallocate_resource(struct resource *root, struct resource *old,
>  
>  	write_lock(&resource_lock);
>  
> -	if ((err = __find_resource(root, old, &new, newsize, constraint)))
> +	if ((err = __find_empty_resource_slot(root, old, &new, newsize, constraint)))
>  		goto out;
>  
>  	if (resource_contains(&new, old)) {
> @@ -729,7 +728,7 @@ int allocate_resource(struct resource *root, struct resource *new,
>  	}
>  
>  	write_lock(&resource_lock);
> -	err = find_resource(root, new, size, &constraint);
> +	err = find_empty_resource_slot(root, new, size, &constraint);
>  	if (err >= 0 && __request_resource(root, new))
>  		err = -EBUSY;
>  	write_unlock(&resource_lock);
> -- 
> 2.30.2
> 




[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux