On Thu, Feb 15, 2024 at 04:21:48PM -0600, Ben Cheatham wrote: > On 2/15/24 3:35 PM, Bjorn Helgaas wrote: > > On Thu, Feb 15, 2024 at 01:40:45PM -0600, Ben Cheatham wrote: > >> +#define NUM_CXL_TIMEOUT_RANGES 9 > > > > I don't think we actually need this constant, do we? > > Not really, just gets rid of a magic number (as well as makes sure > anyone who changes that array remembers to update the array size). My point was that I don't think you need to specify the size of the array at all since it's initialized, and you already use ARRAY_SIZE() elsewhere.