On Thu, Feb 15, 2024 at 02:35:13PM +0100, Alexander Lobakin wrote: > From: Konrad Dybcio <konrad.dybcio@xxxxxxxxxx> > Date: Thu, 15 Feb 2024 11:39:31 +0100 > > > According to [1], msleep should be used for large sleeps, such as the > > 100-ish ms one in this function. Comply with the guide and use it. > > > > [1] https://www.kernel.org/doc/Documentation/timers/timers-howto.txt > > > > Signed-off-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxx> > > --- > > Tested on Qualcomm SC8280XP CRD > > --- > > drivers/pci/controller/dwc/pcie-designware.c | 2 +- > > drivers/pci/controller/dwc/pcie-designware.h | 3 +-- > > 2 files changed, 2 insertions(+), 3 deletions(-) > > > > diff --git a/drivers/pci/controller/dwc/pcie-designware.c b/drivers/pci/controller/dwc/pcie-designware.c > > index 250cf7f40b85..abce6afceb91 100644 > > --- a/drivers/pci/controller/dwc/pcie-designware.c > > +++ b/drivers/pci/controller/dwc/pcie-designware.c > > @@ -655,7 +655,7 @@ int dw_pcie_wait_for_link(struct dw_pcie *pci) > > if (dw_pcie_link_up(pci)) > > break; > > > > - usleep_range(LINK_WAIT_USLEEP_MIN, LINK_WAIT_USLEEP_MAX); > > + msleep(LINK_WAIT_MSLEEP_MAX); > > Just use fsleep(LINK_WAIT_USLEEP_MAX) and let the kernel decide which > function to pick. Odd. https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/timers/timers-howto.rst?id=v6.7#n114 mentions fsleep() (with no real guidance about when to use it), but https://www.kernel.org/doc/Documentation/timers/timers-howto.txt seems to be a stale copy from 2017, before fsleep() was added. I emailed helpdesk@xxxxxxxxxx to see if the stale content can be removed. I do think fsleep() should be more widely used. > > /* Parameters for the waiting for link up routine */ > > #define LINK_WAIT_MAX_RETRIES 10 > > -#define LINK_WAIT_USLEEP_MIN 90000 > > -#define LINK_WAIT_USLEEP_MAX 100000 > > +#define LINK_WAIT_MSLEEP_MAX 100 Since you're touching this anyway, it would be helpful to include the units on the timeout. USLEEP/MSLEEP is definitely a hint, but I think the "SLEEP" part suggests something about atomic/non-atomic context and isn't relevant to the time interval itself, and something like "TIMEOUT" would be better. I think an explicit "_US" or "_MS" would better indicate the units. This is turning into a long tangent, but I'm not a huge fan of the LINK_WAIT_* pattern where I have to look up the code that uses LINK_WAIT_MAX_RETRIES and LINK_WAIT_USLEEP_MAX and do the math to see what the actual timeout is. Obviously not fodder for *this* patch. Bjorn