Re: [PATCH v4 0/6] PCI: controllers: tidy code up

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello,

> > This patch series tidies the code of PCIe dwc controllers and some
> > controllers up.
> 
> Applied to controller/dwc, thank you!
> 
> [01/06] PCI: dwc: Drop host prefix from struct dw_pcie_host_ops members
>         https://git.kernel.org/pci/pci/c/aea370b2aec9
> [02/06] PCI: dwc: Rename .ep_init to .init in struct dw_pcie_ep_ops
>         https://git.kernel.org/pci/pci/c/756dcb5a820a
> [03/06] PCI: dwc: Rename .func_conf_select to .get_dbi_offset in struct dw_pcie_ep_ops
>         https://git.kernel.org/pci/pci/c/641f79beeebc
> [04/06] PCI: dwc: Add dw_pcie_ep_{read,write}_dbi[2] helpers
>         https://git.kernel.org/pci/pci/c/70fa02ca1446
> [05/06] PCI: iproc: Fix -Wvoid-pointer-to-enum-cast warning
>         https://git.kernel.org/pci/pci/c/f72896721621
> [06/06] PCI: rcar-gen4: Fix -Wvoid-pointer-to-enum-cast error
>         https://git.kernel.org/pci/pci/c/7682f19c3c8c

Bjorn, there will be a minor conflict with the controller/layerscape branch
when you pull these changes to apply against our "next"—a side effect of
this particular series, which was rebased against our "next" rather than
being kept aligned with our HEAD branch, no longer including changes
against Frank Li's updates to the driver.

The following simple patch would be needed:

diff --git i/drivers/pci/controller/dwc/pci-layerscape.c w/drivers/pci/controller/dwc/pci-layerscape.c
index 7cdada200de7..9db079bbd947 100644
--- i/drivers/pci/controller/dwc/pci-layerscape.c
+++ w/drivers/pci/controller/dwc/pci-layerscape.c
@@ -278,7 +278,7 @@ static const struct dw_pcie_host_ops ls_pcie_host_ops = {
 };
 
 static const struct dw_pcie_host_ops ls1021a_pcie_host_ops = {
-	.host_init = ls_pcie_host_init,
+	.init = ls_pcie_host_init,
 	.pme_turn_off = ls1021a_pcie_send_turnoff_msg,
 };
 
@@ -290,7 +290,7 @@ static const struct ls_pcie_drvdata ls1021a_drvdata = {
 };
 
 static const struct dw_pcie_host_ops ls1043a_pcie_host_ops = {
-	.host_init = ls_pcie_host_init,
+	.init = ls_pcie_host_init,
 	.pme_turn_off = ls1043a_pcie_send_turnoff_msg,
 };
 
	Krzysztof




[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux