[PATCH] PCI: Treat pci_scan_bridge_extend() 'pass' as int, not boolean

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



From: Bjorn Helgaas <bhelgaas@xxxxxxxxxx>

pci_scan_bridge_extend() and pci_scan_bridge() are designed to be called
twice, with a "pass" parameter to indicate whether it's the first call
(pass 0) or the second (pass 1).

The "pass" is not a boolean, and callers supply 0 or 1.  For readability,
update tests to use "pass == 0" instead of "!pass" and "pass > 0" instead
of "pass".  Update the parameter type from "int" to "unsigned int".

No functional change intended.

Signed-off-by: Bjorn Helgaas <bhelgaas@xxxxxxxxxx>
---
 drivers/pci/probe.c | 11 ++++++-----
 include/linux/pci.h |  2 +-
 2 files changed, 7 insertions(+), 6 deletions(-)

diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index ed6b7f48736a..ce631d02621b 100644
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
@@ -1252,7 +1252,7 @@ static bool pci_ea_fixed_busnrs(struct pci_dev *dev, u8 *sec, u8 *sub)
  */
 static int pci_scan_bridge_extend(struct pci_bus *bus, struct pci_dev *dev,
 				  int max, unsigned int available_buses,
-				  int pass)
+				  unsigned int pass)
 {
 	struct pci_bus *child;
 	int is_cardbus = (dev->hdr_type == PCI_HEADER_TYPE_CARDBUS);
@@ -1284,7 +1284,7 @@ static int pci_scan_bridge_extend(struct pci_bus *bus, struct pci_dev *dev,
 	}
 
 	/* Check if setup is sensible at all */
-	if (!pass &&
+	if (pass == 0 &&
 	    (primary != bus->number || secondary <= bus->number ||
 	     secondary > subordinate)) {
 		pci_info(dev, "bridge configuration invalid ([bus %02x-%02x]), reconfiguring\n",
@@ -1310,7 +1310,7 @@ static int pci_scan_bridge_extend(struct pci_bus *bus, struct pci_dev *dev,
 		 * Bus already configured by firmware, process it in the
 		 * first pass and just note the configuration.
 		 */
-		if (pass)
+		if (pass > 0)
 			goto out;
 
 		/*
@@ -1344,7 +1344,7 @@ static int pci_scan_bridge_extend(struct pci_bus *bus, struct pci_dev *dev,
 		 * We need to assign a number to this bus which we always
 		 * do in the second pass.
 		 */
-		if (!pass) {
+		if (pass == 0) {
 			if (pcibios_assign_all_busses() || broken || is_cardbus)
 
 				/*
@@ -1496,7 +1496,8 @@ static int pci_scan_bridge_extend(struct pci_bus *bus, struct pci_dev *dev,
  *
  * Return: New subordinate number covering all buses behind this bridge.
  */
-int pci_scan_bridge(struct pci_bus *bus, struct pci_dev *dev, int max, int pass)
+int pci_scan_bridge(struct pci_bus *bus, struct pci_dev *dev, int max,
+		    unsigned int pass)
 {
 	return pci_scan_bridge_extend(bus, dev, max, 0, pass);
 }
diff --git a/include/linux/pci.h b/include/linux/pci.h
index 4ebecc7896ef..6b1f13e941bf 100644
--- a/include/linux/pci.h
+++ b/include/linux/pci.h
@@ -1616,7 +1616,7 @@ int pci_add_dynid(struct pci_driver *drv,
 const struct pci_device_id *pci_match_id(const struct pci_device_id *ids,
 					 struct pci_dev *dev);
 int pci_scan_bridge(struct pci_bus *bus, struct pci_dev *dev, int max,
-		    int pass);
+		    unsigned int pass);
 
 void pci_walk_bus(struct pci_bus *top, int (*cb)(struct pci_dev *, void *),
 		  void *userdata);
-- 
2.34.1





[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux