On Tue, Mar 07, 2023 at 09:19:29AM +0100, Krzysztof Kozlowski wrote: > On 06/03/2023 16:32, Manivannan Sadhasivam wrote: > > As per Qualcomm's internal documentation, the name of the region is "mhi" > > and not "mmio". So let's rename it to follow the convention. > > > > Signed-off-by: Manivannan Sadhasivam <manivannan.sadhasivam@xxxxxxxxxx> > > --- > > > > > > > @@ -477,16 +477,16 @@ static int qcom_pcie_ep_get_io_resources(struct platform_device *pdev, > > if (IS_ERR(pcie_ep->elbi)) > > return PTR_ERR(pcie_ep->elbi); > > > > - pcie_ep->mmio_res = platform_get_resource_byname(pdev, IORESOURCE_MEM, > > - "mmio"); > > - if (!pcie_ep->mmio_res) { > > - dev_err(dev, "Failed to get mmio resource\n"); > > + pcie_ep->mhi_res = platform_get_resource_byname(pdev, IORESOURCE_MEM, > > + "mhi"); > > That's an ABI break. Patchset is also non-bisectable. > As agreed, I will drop this patch in next revision. Thanks, Mani > Best regards, > Krzysztof > -- மணிவண்ணன் சதாசிவம்