On Tue, Feb 21, 2023 at 11:46:52AM +0800, Cai Huoqing wrote: > From: Cai huoqing <cai.huoqing@xxxxxxxxx> > > Rename dw_edma_core_ops structure to dw_edma_plat_ops, the ops is platform > specific operations: the DMA device environment configs like IRQs, > address translation, etc. > > The dw_edma_plat_ops name was supposed to refer to the platform which > the DW eDMA engine is embedded to, like PCIe end-point (accessible via > the PCIe bus) or a PCIe root port (directly accessible by CPU). > Needless to say that for them the IRQ-vector and PCI-addresses are > differently determined. The suggested name has a connection with the > kernel platform device only as a private case of the eDMA/hDMA embedded > into the DW PCI Root ports, though basically it was supposed to refer to > any platform in which the DMA hardware lives. > > Anyway the renaming was necessary to distinguish two types of > the implementation callbacks: > 1. DW eDMA/hDMA IP-core specific operations: device-specific CSR > setups in one or another aspect of the DMA-engine initialization. > 2. DW eDMA/hDMA platform specific operations: the DMA device > environment configs like IRQs, address translation, etc. > > dw_edma_core_ops is supposed to be used for the case 1, and > dw_edma_plat_ops - for the case 2. > > Signed-off-by: Cai huoqing <cai.huoqing@xxxxxxxxx> > --- > v3->v4: > [1/4] > 1.Update the structure name dw_edma_plat_ops in commit log > 2.Fix code stytle. > > v3 link: > https://lore.kernel.org/lkml/20230213132411.65524-2-cai.huoqing@xxxxxxxxx/ > > drivers/dma/dw-edma/dw-edma-pcie.c | 4 ++-- > drivers/pci/controller/dwc/pcie-designware.c | 2 +- > include/linux/dma/edma.h | 7 ++++--- > 3 files changed, 7 insertions(+), 6 deletions(-) > > diff --git a/drivers/dma/dw-edma/dw-edma-pcie.c b/drivers/dma/dw-edma/dw-edma-pcie.c > index 2b40f2b44f5e..798cb0662cef 100644 > --- a/drivers/dma/dw-edma/dw-edma-pcie.c > +++ b/drivers/dma/dw-edma/dw-edma-pcie.c > @@ -109,7 +109,7 @@ static u64 dw_edma_pcie_address(struct device *dev, phys_addr_t cpu_addr) > return region.start; > } > > -static const struct dw_edma_core_ops dw_edma_pcie_core_ops = { > +static const struct dw_edma_plat_ops dw_edma_plat_ops = { Why have you changed the prefix since v3? The instance was correct there preserving the local naming convention: -static const struct dw_edma_core_ops dw_edma_pcie_core_ops = { +static const struct dw_edma_plat_ops dw_edma_pcie_plat_ops = { > .irq_vector = dw_edma_pcie_irq_vector, > .pci_address = dw_edma_pcie_address, > }; > @@ -225,7 +225,7 @@ static int dw_edma_pcie_probe(struct pci_dev *pdev, > > chip->mf = vsec_data.mf; > chip->nr_irqs = nr_irqs; > - chip->ops = &dw_edma_pcie_core_ops; > + chip->ops = &dw_edma_plat_ops; ditto > > chip->ll_wr_cnt = vsec_data.wr_ch_cnt; > chip->ll_rd_cnt = vsec_data.rd_ch_cnt; > diff --git a/drivers/pci/controller/dwc/pcie-designware.c b/drivers/pci/controller/dwc/pcie-designware.c > index 53a16b8b6ac2..44e90b71d429 100644 > --- a/drivers/pci/controller/dwc/pcie-designware.c > +++ b/drivers/pci/controller/dwc/pcie-designware.c > @@ -828,7 +828,7 @@ static int dw_pcie_edma_irq_vector(struct device *dev, unsigned int nr) > return platform_get_irq_byname_optional(pdev, name); > } > > -static struct dw_edma_core_ops dw_pcie_edma_ops = { > +static struct dw_edma_plat_ops dw_pcie_edma_ops = { > .irq_vector = dw_pcie_edma_irq_vector, > }; > > diff --git a/include/linux/dma/edma.h b/include/linux/dma/edma.h > index d2638d9259dc..3080747689f6 100644 > --- a/include/linux/dma/edma.h > +++ b/include/linux/dma/edma.h > @@ -40,7 +40,7 @@ struct dw_edma_region { > * iATU windows. That will be done by the controller > * automatically. > */ > -struct dw_edma_core_ops { > +struct dw_edma_plat_ops { > int (*irq_vector)(struct device *dev, unsigned int nr); > u64 (*pci_address)(struct device *dev, phys_addr_t cpu_addr); > }; > @@ -48,7 +48,8 @@ struct dw_edma_core_ops { > enum dw_edma_map_format { > EDMA_MF_EDMA_LEGACY = 0x0, > EDMA_MF_EDMA_UNROLL = 0x1, > - EDMA_MF_HDMA_COMPAT = 0x5 > + EDMA_MF_HDMA_COMPAT = 0x5, > + EDMA_MF_HDMA_NATIVE = 0x7, Just noticed that this change isn't related with what the patch log states. Please move it to [PATCH vX 3/4] "dmaengine: dw-edma: Add support for native HDMA" of the series which introduces the new mapping. -Serge(y) > }; > > /** > @@ -80,7 +81,7 @@ enum dw_edma_chip_flags { > struct dw_edma_chip { > struct device *dev; > int nr_irqs; > - const struct dw_edma_core_ops *ops; > + const struct dw_edma_plat_ops *ops; > u32 flags; > > void __iomem *reg_base; > -- > 2.34.1 >