On Mon, 21 Nov 2022 14:36:22 +0000, Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote: > > irq_domain::dev is a misnomer as it's usually the rule that a device > pointer points to something which is directly related to the instance. > > irq_domain::dev can point to some other device for power management to > ensure that this underlying device is not powered down when an interrupt is > allocated. > > The upcoming per device MSI domains really require a pointer to the device > which instantiated the irq domain and not to some random other device which > is required for power management down the chain. > > Rename irq_domain::dev to irq_domain::pm_dev and fixup the few sites which > use that pointer. > > Conversion was done with the help of coccinelle. > > Signed-off-by: Thomas Gleixner <tglx@xxxxxxxxxxxxx> > Reviewed-by: Jason Gunthorpe <jgg@xxxxxxxxxx> > --- > drivers/irqchip/irq-gic.c | 4 ++-- > include/linux/irqdomain.h | 6 +++--- > kernel/irq/chip.c | 8 ++++---- > 3 files changed, 9 insertions(+), 9 deletions(-) Reviewed-by: Marc Zyngier <maz@xxxxxxxxxx> M. -- Without deviation from the norm, progress is not possible.