On Tuesday 06 September 2022 13:43:00 Dmitry Torokhov wrote: > + ret = gpiod_set_consumer_name(hipcie->reset_gpio, > + "PCIe device power control"); Just unrelated thing, I know it was there before, but I saw it just now and have to comment it: This is absolute nonsense name. "reset-gpios" device tree property specifies PERST# signal pin (PciE ReSeT) as defined in PCIe CEM (Card ElectroMagnetic) specification and it has absolute nothing with PCIe power control. My suggestion for maintainers would be to remove this critic name at all as it would just mislead other people reading that code. > + if (ret) { > + dev_err(dev, "unable to set reset gpio name: %d\n", ret); > + return ret; > }