On Mon, Aug 08, 2022 at 09:07:34PM -0500, Bjorn Helgaas wrote: > This doesn't tell me what the advantage of this patch is, since I > don't think *this* patch uses heap allocation. > > As far as I can tell, this particular patch doesn't improve safety or > readability, so "convert X to Y even though we don't use any fancy Y > features" is a pointless message. > > But if printbufs are better than seq_buf overall, and converting this > gets us closer to the goal of removing seq_buf completely, that's a > perfectly acceptable reason. Just say that. Which still brings me back to a point made long time ago: Why are we doing the renaming to start with? Add the new functionality and or changes to seq_buf gradually instead of doing a tree wide sweep. I don't think the new naming has a huge advantage (in fact I think the old one actually is a little better, but the biggest argument here really is to not change something if we don't have to). That will massively reduce the churn at the cost of Kent having to rework the code a bit, but that seems like a worthwhile tradeoff and one that we've usuall made in the past.