On Wed, Feb 23, 2022 at 12:00:56PM -0600, Bjorn Helgaas wrote: > > static int pci_dma_configure(struct device *dev) > > { > > + struct pci_driver *driver = to_pci_driver(dev->driver); > > struct device *bridge; > > int ret = 0; > > > > + if (!driver->no_kernel_api_dma) { > > Ugh. Double negative, totally agree this needs a better name that > reverses the sense. Every place you use it, you negate it again. Greg came up with driver_managed_dma which is in the v6 version: https://lore.kernel.org/all/20220218005521.172832-5-baolu.lu@xxxxxxxxxxxxxxx/ Thanks, Jason