On Mon, Feb 14, 2022 at 08:38:42AM -0400, Jason Gunthorpe wrote: > On Mon, Feb 14, 2022 at 11:03:42AM +0100, Greg Kroah-Hartman wrote: > > On Tue, Jan 04, 2022 at 09:56:37AM +0800, Lu Baolu wrote: > > > Multiple PCI devices may be placed in the same IOMMU group because > > > they cannot be isolated from each other. These devices must either be > > > entirely under kernel control or userspace control, never a mixture. This > > > checks and sets DMA ownership during driver binding, and release the > > > ownership during driver unbinding. > > > > > > The device driver may set a new flag (no_kernel_api_dma) to skip calling > > > iommu_device_use_dma_api() during the binding process. For instance, the > > > userspace framework drivers (vfio etc.) which need to manually claim > > > their own dma ownership when assigning the device to userspace. > > > > > > Signed-off-by: Lu Baolu <baolu.lu@xxxxxxxxxxxxxxx> > > > include/linux/pci.h | 5 +++++ > > > drivers/pci/pci-driver.c | 21 +++++++++++++++++++++ > > > 2 files changed, 26 insertions(+) > > > > > > diff --git a/include/linux/pci.h b/include/linux/pci.h > > > index 18a75c8e615c..d29a990e3f02 100644 > > > +++ b/include/linux/pci.h > > > @@ -882,6 +882,10 @@ struct module; > > > * created once it is bound to the driver. > > > * @driver: Driver model structure. > > > * @dynids: List of dynamically added device IDs. > > > + * @no_kernel_api_dma: Device driver doesn't use kernel DMA API for DMA. > > > + * Drivers which don't require DMA or want to manually claim the > > > + * owner type (e.g. userspace driver frameworks) could set this > > > + * flag. > > > > Again with the bikeshedding, but this name is a bit odd. Of course it's > > in the kernel, this is all kernel code, so you can drop that. And > > again, "negative" flags are rough. So maybe just "prevent_dma"? > > That is misleading too, it is not that DMA is prevented, but that the > kernel's dma_api has not been setup. "has not been" or "will not be"? What you want to prevent is the iommu core claiming the device automatically, right? So how about "prevent_iommu_dma"? naming is hard, greg k-h