On 1/28/22 12:48, Brent Spillner wrote: > It seems like the multiline string literal is your main pain point--- would > > +#ifdef CONFIG_ACPI > + if (acpi_noirq) > + msg = "; consider removing acpi=noirq"; > + else > + msg = "; recommend verifying UEFI/BIOS > IRQ options"; > +#else > + msg = "; recommend verifying UEFI/BIOS IRQ > options or enabling ACPI"; > +#endif > > be OK without going to IS_ENABLED()? (Personally, I think the #ifdef > style is more readable.) I think that's _better_ than what was in the patch. But, even with it, I still think the #ifdef mess borders on unreadable. But, if Bjorn likes it, then go for it. :)