On Tue, Oct 19, 2021 at 05:58:58PM +0800, Meng Li wrote: > From: Andrey Gusakov <andrey.gusakov@xxxxxxxxxxxxxxxxxx> > > Add PCIe regulators for KingFisher board. Please pay attention to the existing code and history. Your current subject line is: pci: pcie-rcar: add regulators support which looks nothing like the history: $ git log --oneline drivers/pci/controller/pcie-rcar-host.c 861e133ba268 ("PCI: rcar-host: Remove unneeded includes") a115b1bd3af0 ("PCI: rcar: Add L1 link state fix into data abort hook") d21faba11693 ("PCI: Bulk conversion to generic_handle_domain_irq()") 83ed8d4fa656 ("PCI: rcar: Convert to MSI domains") 93cd1bb4862d ("PCI: rcar: Don't allocate extra memory for the MSI capture address") c4e0fec2f7ee ("PCI: rcar: Always allocate MSI addresses in 32bit space") 6e8e137abeab ("PCI: rcar: Drop unused members from struct rcar_pcie_host") b64aa11eb2dd ("PCI: Set bridge map_irq and swizzle_irq to default functions") 669cbc708122 ("PCI: Move DT resource setup into devm_pci_alloc_host_bridge()") b411b2e1adb9 ("PCI: rcar: Use struct pci_host_bridge.windows list directly") 61f11f8250e2 ("PCI: rcar: Use devm_pci_alloc_host_bridge()") 4f5c883d7815 ("PCI: Move setting pci_host_bridge.busnr out of host drivers") 6176a5f32751 ("PCI: rcar: Use pci_is_root_bus() to check if bus is root bus") 6a589900d050 ("PCI: Set default bridge parent device") a68e06e729b1 ("PCI: rcar: Fix runtime PM imbalance on error") 56d292348470 ("PCI: rcar: Use pci_host_probe() to register host") 78a0d7f2f5a3 ("PCI: rcar: Move shareable code to a common file") a18f4b6ea50b ("PCI: rcar: Rename pcie-rcar.c to pcie-rcar-host.c") You could use something like: PCI: rcar-host: Add regulator support for KingFisher > + host->pcie3v3 = devm_regulator_get_optional(dev, "pcie3v3"); > + if (IS_ERR(host->pcie3v3)) { +1 to Geert's comments. Sprinkling IS_ERR() everywhere is kind of ugly. host->pcie3v3 should be NULL if not present. Bjorn