Re: [PATCH linux-next] PCI: Fix the order in unregister path

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



August 26, 2021 8:01 PM, "Rob Herring" <robh@xxxxxxxxxx> wrote:

> On Wed, Aug 25, 2021 at 10:57 PM <yajun.deng@xxxxxxxxx> wrote:
> 
>> August 25, 2021 9:55 PM, "Rob Herring" <robh@xxxxxxxxxx> wrote:
>> 
>> On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@xxxxxxxxx> wrote:
>> 
>> device_del() should be called first and then called put_device() in
>> unregister path, becase if that the final reference count, the device
>> will be cleaned up via device_release() above. So use device_unregister()
>> instead.
>> 
>> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
>> Signed-off-by: Yajun Deng <yajun.deng@xxxxxxxxx>
>> ---
>> drivers/pci/probe.c | 4 +---
>> 1 file changed, 1 insertion(+), 3 deletions(-)
>> 
>> NAK.
>> 
>> The current code is correct. Go read the comments for device_add/device_del.
>> 
>> But the device_unregister() is only contains device_del() and put_device(). It just put
>> device_del() before put_device().
> 
> And that is the wrong order as we want to undo what the code above
> did. The put_device here is for the get_device we did. The put_device
> in device_unregister is for the get_device that device_register did
> (on success only).
> 
> Logically, it is wrong too to call unregister if register failed. That
> would be like doing this:
> 
> p = malloc(1);
> if (!p)
> free(p);
>
This is the raw code:
        err = device_register(&bus->dev);
        if (err)
                goto unregister;
unregister:
        put_device(&bridge->dev);
        device_del(&bridge->dev);

This is my code:
        err = device_register(&bus->dev);
        if (err)
                goto unregister;
 unregister:
        device_unregister(&bridge->dev);


The parameter in  device_register() is bus->dev, but the parameter in device_unregister() is bridge->dev.The are different.
The bridge->dev is already success before called device_register().So it wouldn't be happen like your code.

 
> Rob




[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux