On Thu, Jul 22 2021 at 14:46, Marc Zyngier wrote: > On Wed, 21 Jul 2021 23:57:55 +0100, > Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote: >> msix_mask_all() is invoked before the msi descriptors are >> allocated. msi_desc::masked is actually a misnomer because it's not like >> the name suggests a boolean representing the masked state. It's caching >> the content of the PCI_MSIX_ENTRY_VECTOR_CTRL part of the corresponding >> table entry. Right now this is just using bit 0 (the mask bit), but is >> that true forever? So we actually should rename that member to >> vector_ctrl or such. > > To follow-up with this forward looking statement, should we only keep > bit 0 when reading PCI_MSIX_ENTRY_VECTOR_CTRL? I.e.: > > entry->masked = (readl(addr + PCI_MSIX_ENTRY_VECTOR_CTRL) & > PCI_MSIX_ENTRY_CTRL_MASKBIT); > > Or do we want to cache the whole register? In which case I'm all for > the suggesting renaming (though 'masked' is shared with the old-school > multi-MSI). We want to cache the whole register because that's what we need to write when the mask bit is toggled. Thanks, tglx