From: Bjorn Helgaas <bhelgaas@xxxxxxxxxx> This is a v3 posting of Saheed's ASPM cleanup. The intent is that this is strictly cleanup, no functional changes at all. We want to simplify the code by removing struct aspm_register_info and pcie_get_aspm_reg(). These are only used to read and store register info, but the info is only used in one place, so the function and struct only make things more complicated. Previous postings: v2: https://lore.kernel.org/r/20200924142443.260861-2-refactormyself@xxxxxxxxx v1: https://lore.kernel.org/r/20200923231517.221310-1-refactormyself@xxxxxxxxx Bjorn Helgaas (5): PCI/ASPM: Move pci_clear_and_set_dword() earlier PCI/ASPM: Move LTR path check to where it's used PCI/ASPM: Use 'parent' and 'child' for readability PCI/ASPM: Remove struct aspm_register_info.l1ss_ctl2 (unused) PCI/ASPM: Pass L1SS Capabilities value, not struct aspm_register_info Saheed O. Bolarinwa (7): PCI/ASPM: Remove struct aspm_register_info.support PCI/ASPM: Remove struct aspm_register_info.enabled PCI/ASPM: Remove struct aspm_register_info.latency_encoding PCI/ASPM: Remove struct aspm_register_info.l1ss_cap_ptr PCI/ASPM: Remove struct aspm_register_info.l1ss_ctl1 PCI/ASPM: Remove struct aspm_register_info.l1ss_cap PCI/ASPM: Remove struct pcie_link_state.l1ss drivers/pci/pcie/aspm.c | 265 +++++++++++++++------------------- drivers/pci/probe.c | 3 + include/linux/pci.h | 1 + include/uapi/linux/pci_regs.h | 2 + 4 files changed, 120 insertions(+), 151 deletions(-) -- 2.25.1