Re: [PATCH 22/37] move round_up/down to kernel.h

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, 20 Jan 2010, Yinghai Lu wrote:

> like this, using DIVIDE for all ?

I liked the __round_mask better


> -#define __round_mask(x,y) ((__typeof__(x))((y)-1))
> -#define round_up(x,y) ((((x)-1) | __round_mask(x,y))+1)
> -#define round_down(x,y) ((x) & ~__round_mask(x,y))
> +#define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y))
> +#define rounddown(x, y) (((x) / (y)) * (y))

> +#define round_up(x,y) roundup(x,y)
> +#define round_down(x,y) rounddown(x,y)

Why two aliases? Make the use consistent throughout the source.

--
To unsubscribe from this list: send the line "unsubscribe linux-pci" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html

[Index of Archives]     [DMA Engine]     [Linux Coverity]     [Linux USB]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]     [Greybus]

  Powered by Linux