Re: [PATCH v5 RESEND 13/17] parisc: mm: Convert to GENERIC_IOREMAP

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 05/16/23 at 09:52am, Mike Rapoport wrote:
> On Mon, May 15, 2023 at 05:08:44PM +0800, Baoquan He wrote:
> > By taking GENERIC_IOREMAP method, the generic generic_ioremap_prot(),
> > generic_iounmap(), and their generic wrapper ioremap_prot(), ioremap()
> > and iounmap() are all visible and available to arch. Arch needs to
> > provide wrapper functions to override the generic versions if there's
> > arch specific handling in its ioremap_prot(), ioremap() or iounmap().
> > This change will simplify implementation by removing duplicated codes
> > with generic_ioremap_prot() and generic_iounmap(), and has the equivalent
> > functioality as before.
> > 
> > Here, add wrapper function ioremap_prot() for parisc's special operation
> > when iounmap().
> > 
> > Meanwhile, add macro ARCH_HAS_IOREMAP_WC since the added ioremap_wc()
> > will conflict with the one in include/asm-generic/iomap.h, then an
> > compiling error is seen:
> 
> Looks like this paragraph is outdated, as an earlier patch in the series
> removes use of ARCH_HAS_IOREMAP_WC?

You are right, I forgot updating this patchlog after removing
ARCH_HAS_IOREMAP_WC. Will update in new post. Thanks.

>  
> > ./include/asm-generic/iomap.h:97: warning: "ioremap_wc" redefined
> >    97 | #define ioremap_wc ioremap
> > 
> > And benefit from the commit 437b6b35362b ("parisc: Use the generic
> > IO helpers"), those macros don't need be added any more.
> > 
> > Signed-off-by: Baoquan He <bhe@xxxxxxxxxx>
> > Acked-by: Helge Deller <deller@xxxxxx>
> > Cc: "James E.J. Bottomley" <James.Bottomley@xxxxxxxxxxxxxxxxxxxxx>
> > Cc: linux-parisc@xxxxxxxxxxxxxxx
> > ---
> >  arch/parisc/Kconfig          |  1 +
> >  arch/parisc/include/asm/io.h | 15 ++++++---
> >  arch/parisc/mm/ioremap.c     | 62 +++---------------------------------
> >  3 files changed, 15 insertions(+), 63 deletions(-)
> > 
> > diff --git a/arch/parisc/Kconfig b/arch/parisc/Kconfig
> > index 466a25525364..be6ab4530390 100644
> > --- a/arch/parisc/Kconfig
> > +++ b/arch/parisc/Kconfig
> > @@ -36,6 +36,7 @@ config PARISC
> >  	select GENERIC_ATOMIC64 if !64BIT
> >  	select GENERIC_IRQ_PROBE
> >  	select GENERIC_PCI_IOMAP
> > +	select GENERIC_IOREMAP
> >  	select ARCH_HAVE_NMI_SAFE_CMPXCHG
> >  	select GENERIC_SMP_IDLE_THREAD
> >  	select GENERIC_ARCH_TOPOLOGY if SMP
> > diff --git a/arch/parisc/include/asm/io.h b/arch/parisc/include/asm/io.h
> > index c05e781be2f5..366537042465 100644
> > --- a/arch/parisc/include/asm/io.h
> > +++ b/arch/parisc/include/asm/io.h
> > @@ -125,12 +125,17 @@ static inline void gsc_writeq(unsigned long long val, unsigned long addr)
> >  /*
> >   * The standard PCI ioremap interfaces
> >   */
> > -void __iomem *ioremap(unsigned long offset, unsigned long size);
> > -#define ioremap_wc			ioremap
> > -#define ioremap_uc			ioremap
> > -#define pci_iounmap			pci_iounmap
> > +#define ioremap_prot ioremap_prot
> > +
> > +#define _PAGE_IOREMAP (_PAGE_PRESENT | _PAGE_RW | _PAGE_DIRTY | \
> > +		       _PAGE_ACCESSED | _PAGE_NO_CACHE)
> >  
> > -extern void iounmap(const volatile void __iomem *addr);
> > +#define ioremap_wc(addr, size)  \
> > +	ioremap_prot((addr), (size), _PAGE_IOREMAP)
> > +#define ioremap_uc(addr, size)  \
> > +	ioremap_prot((addr), (size), _PAGE_IOREMAP)
> > +
> > +#define pci_iounmap			pci_iounmap
> >  
> >  void memset_io(volatile void __iomem *addr, unsigned char val, int count);
> >  void memcpy_fromio(void *dst, const volatile void __iomem *src, int count);
> > diff --git a/arch/parisc/mm/ioremap.c b/arch/parisc/mm/ioremap.c
> > index 345ff0b66499..fd996472dfe7 100644
> > --- a/arch/parisc/mm/ioremap.c
> > +++ b/arch/parisc/mm/ioremap.c
> > @@ -13,25 +13,9 @@
> >  #include <linux/io.h>
> >  #include <linux/mm.h>
> >  
> > -/*
> > - * Generic mapping function (not visible outside):
> > - */
> > -
> > -/*
> > - * Remap an arbitrary physical address space into the kernel virtual
> > - * address space.
> > - *
> > - * NOTE! We need to allow non-page-aligned mappings too: we will obviously
> > - * have to convert them into an offset in a page-aligned mapping, but the
> > - * caller shouldn't need to know that small detail.
> > - */
> > -void __iomem *ioremap(unsigned long phys_addr, unsigned long size)
> > +void __iomem *ioremap_prot(phys_addr_t phys_addr, size_t size,
> > +			   unsigned long prot)
> >  {
> > -	void __iomem *addr;
> > -	struct vm_struct *area;
> > -	unsigned long offset, last_addr;
> > -	pgprot_t pgprot;
> > -
> >  #ifdef CONFIG_EISA
> >  	unsigned long end = phys_addr + size - 1;
> >  	/* Support EISA addresses */
> > @@ -40,11 +24,6 @@ void __iomem *ioremap(unsigned long phys_addr, unsigned long size)
> >  		phys_addr |= F_EXTEND(0xfc000000);
> >  #endif
> >  
> > -	/* Don't allow wraparound or zero size */
> > -	last_addr = phys_addr + size - 1;
> > -	if (!size || last_addr < phys_addr)
> > -		return NULL;
> > -
> >  	/*
> >  	 * Don't allow anybody to remap normal RAM that we're using..
> >  	 */
> > @@ -62,39 +41,6 @@ void __iomem *ioremap(unsigned long phys_addr, unsigned long size)
> >  		}
> >  	}
> >  
> > -	pgprot = __pgprot(_PAGE_PRESENT | _PAGE_RW | _PAGE_DIRTY |
> > -			  _PAGE_ACCESSED | _PAGE_NO_CACHE);
> > -
> > -	/*
> > -	 * Mappings have to be page-aligned
> > -	 */
> > -	offset = phys_addr & ~PAGE_MASK;
> > -	phys_addr &= PAGE_MASK;
> > -	size = PAGE_ALIGN(last_addr + 1) - phys_addr;
> > -
> > -	/*
> > -	 * Ok, go for it..
> > -	 */
> > -	area = get_vm_area(size, VM_IOREMAP);
> > -	if (!area)
> > -		return NULL;
> > -
> > -	addr = (void __iomem *) area->addr;
> > -	if (ioremap_page_range((unsigned long)addr, (unsigned long)addr + size,
> > -			       phys_addr, pgprot)) {
> > -		vunmap(addr);
> > -		return NULL;
> > -	}
> > -
> > -	return (void __iomem *) (offset + (char __iomem *)addr);
> > -}
> > -EXPORT_SYMBOL(ioremap);
> > -
> > -void iounmap(const volatile void __iomem *io_addr)
> > -{
> > -	unsigned long addr = (unsigned long)io_addr & PAGE_MASK;
> > -
> > -	if (is_vmalloc_addr((void *)addr))
> > -		vunmap((void *)addr);
> > +	return generic_ioremap_prot(phys_addr, size, __pgprot(prot));
> >  }
> > -EXPORT_SYMBOL(iounmap);
> > +EXPORT_SYMBOL(ioremap_prot);
> > -- 
> > 2.34.1
> > 
> > 
> 
> -- 
> Sincerely yours,
> Mike.
> 




[Index of Archives]     [Linux SoC]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux