On Thu, 20 Oct 2022, Helge Deller wrote: > On 10/20/22 22:34, Mikulas Patocka wrote: > > > > > > On Thu, 20 Oct 2022, Helge Deller wrote: > > > > > On 10/20/22 21:57, Mikulas Patocka wrote: > > > > > > > > > > > > On Thu, 20 Oct 2022, Helge Deller wrote: > > > > > > > > > On 10/20/22 20:01, Helge Deller wrote: > > > > > > On 10/20/22 15:26, Mikulas Patocka wrote: > > > > > > > On Thu, 20 Oct 2022, Helge Deller wrote: > > > > > > > > > > > > > > > Your serial ports don't seem to be detected and thus > > > > > > > > missing...?! > > > > > > > > > > > > > > It seems to be so. Does it work on your C8000? - if it does, send > > > > > > > me > > > > > > > your > > > > > > > config and I'll find the difference. > > > > > > > > > > Works for me on c8k with serial console (parameter console=ttyS0): > > > > > config attached. > > > > > > > > Thanks. CONFIG_GSC=y fixed it for me. > > > > > > Good. > > > > > > > Maybe you should update the help text for CONFIG_GSC. It says that it is > > > > "not found in B1000, C3000, J5000, A500, L1000, N4000 and upwards" - so > > > > I > > > > turned it off when making my config. > > > > > > The help text is actually correct. > > > Your C8000 does not has a GSC bus, so why does CONFIG_GSC=n disables your > > > serial ports? > > > Needs checking.. > > > > > > Helge > > > > There's drivers/tty/serial/8250/Kconfig: > > config SERIAL_8250_GSC > > tristate > > depends on SERIAL_8250 && GSC > > default SERIAL_8250 > > > > drivers/tty/serial/8250/Makefile: > > obj-$(CONFIG_SERIAL_8250_GSC) += 8250_gsc.o > > > > drivers/tty/serial/8250/8250_gsc.c contains this device table: > > static const struct parisc_device_id serial_tbl[] __initconst = { > > { HPHW_FIO, HVERSION_REV_ANY_ID, HVERSION_ANY_ID, 0x00075 }, > > { HPHW_FIO, HVERSION_REV_ANY_ID, HVERSION_ANY_ID, 0x0008c }, > > { HPHW_FIO, HVERSION_REV_ANY_ID, HVERSION_ANY_ID, 0x0008d }, > > { HPHW_FIO, HVERSION_REV_ANY_ID, HVERSION_ANY_ID, 0x000ad }, <--- > > this matches the serial port on C8000 > > { 0 } > > }; > > > > So, perhaps it should depend on CONFIG_PARISC instead of CONFIG_GSC. > > Right, I just came to the same conclusion. > Do you want to post a patch here on the list? > > Helge I think you should do it. It would be best to rename that file from 8250_gsc.c to 8250_parisc.c and I don't know how to make a patch that renames a file - you should rename the file in git and send a pull request to Linus. Mikulas