Hi Linus, please pull the parisc architecture updates for kernel 5.15-rc1 from: http://git.kernel.org/pub/scm/linux/kernel/git/deller/parisc-linux.git tags/for-5.15/parisc Changes in this patchset include: - Fix a kernel crash when a signal is delivered to bad userspace stack - Fix fall-through warnings in math-emu code - Increase size of gcc stack frame check - Switch coding from 'pci_' to 'dma_' API - Make struct parisc_driver::remove() return void - Some parisc related Makefile changes - Minor cleanups, e.g. change to octal permissions, fix macro collisions, fix PMD_ORDER collision, replace spaces with tabs Thanks, Helge ---------------------------------------------------------------- The following changes since commit 7d2a07b769330c34b4deabeed939325c77a7ec2f: Linux 5.14 (2021-08-29 15:04:50 -0700) are available in the Git repository at: http://git.kernel.org/pub/scm/linux/kernel/git/deller/parisc-linux.git tags/for-5.15/parisc for you to fetch changes up to 6f1fce595b78b775d7fb585c15c2dc3a6994f96e: parisc: math-emu: Fix fall-through warnings (2021-09-01 22:18:18 +0200) ---------------------------------------------------------------- parisc architecture updates for kernel 5.15: - Fix a kernel crash when a signal is delivered to bad userspace stack - Fix fall-through warnings in math-emu code - Increase size of gcc stack frame check - Switch coding from 'pci_' to 'dma_' API - Make struct parisc_driver::remove() return void - Some parisc related Makefile changes - Minor cleanups, e.g. change to octal permissions, fix macro collisions, fix PMD_ORDER collision, replace spaces with tabs ---------------------------------------------------------------- Christophe JAILLET (2): parisc: switch from 'pci_' to 'dma_' API parisc/parport_gsc: switch from 'pci_' to 'dma_' API Helge Deller (2): parisc: Increase size of gcc stack frame check parisc: math-emu: Fix fall-through warnings Jinchao Wang (1): parisc: Replace symbolic permissions with octal permissions Kees Cook (1): parisc: math-emu: Avoid "fmt" macro collision Masahiro Yamada (3): parisc: remove unused arch/parisc/boot/install.sh and its phony target parisc: move core-y in arch/parisc/Makefile to arch/parisc/Kbuild parisc: Fix compile failure when building 64-bit kernel natively Matthew Wilcox (Oracle) (1): parisc: Rename PMD_ORDER to PMD_TABLE_ORDER Mikulas Patocka (1): parisc: fix crash with signals and alloca Shubhankar Kuranagatti (1): parisc: ccio-dma.c: Added tab instead of spaces Uwe Kleine-König (1): parisc: Make struct parisc_driver::remove() return void Makefile | 5 ++ arch/parisc/Kbuild | 1 + arch/parisc/Makefile | 9 +-- arch/parisc/boot/Makefile | 4 -- arch/parisc/boot/install.sh | 65 ---------------------- arch/parisc/include/asm/parisc-device.h | 4 +- arch/parisc/include/asm/pgalloc.h | 6 +- arch/parisc/include/asm/pgtable.h | 4 +- arch/parisc/kernel/signal.c | 6 ++ arch/parisc/math-emu/decode_exc.c | 4 +- arch/parisc/math-emu/fpudispatch.c | 56 ++++++++++++++++++- arch/parisc/mm/init.c | 4 +- drivers/char/ipmi/ipmi_si.h | 2 +- drivers/char/ipmi/ipmi_si_intf.c | 6 +- drivers/char/ipmi/ipmi_si_parisc.c | 4 +- drivers/char/ipmi/ipmi_si_platform.c | 4 +- drivers/input/keyboard/hilkbd.c | 4 +- drivers/input/serio/gscps2.c | 3 +- drivers/net/ethernet/i825xx/lasi_82596.c | 3 +- drivers/parisc/ccio-dma.c | 94 ++++++++++++++++---------------- drivers/parisc/led.c | 4 +- drivers/parport/parport_gsc.c | 8 +-- drivers/scsi/lasi700.c | 4 +- drivers/scsi/zalon.c | 4 +- drivers/tty/serial/mux.c | 3 +- lib/Kconfig.debug | 2 +- scripts/subarch.include | 2 +- sound/parisc/harmony.c | 3 +- 28 files changed, 147 insertions(+), 171 deletions(-) delete mode 100644 arch/parisc/boot/install.sh