On Wed, May 06, 2020 at 10:44:15AM -0700, Linus Torvalds wrote: > So while I think using a consistent convention is good, and it's true > that there is a difference in the convention between the two cases > ("unsafe" at the beginning vs end), one of them is actually about the > safety and security of the operation (and we have automated logic > these days to verify it on x86), the other has nothing to do with > "safety", really. > > Would it be better to standardize around a "probe_xyz()" naming? So: probe_strncpy, probe_strncpy_user, probe_strnlen_user? Sounds weird, but at least it is consistent. > Or perhaps a "xyz_nofault()" naming? That sounds a little better: strncpy_nofault, strncpy_user_nofault, strnlen_user_nofault > I realize this is nit-picky, and I think the patch series as-is is > already an improvement, but I do think our naming in this area is > really quite bad. Always open for improvements :) > The fact that we have "probe_kernel_read()" but then > "strncpy_from_user_unsafe()" for the _same_ conceptual difference > really tells me how inconsistent the naming for these kinds of "we > can't take page faults" is. No? True. If we wanted to do _nofaul, what would the basic read/write versions be?