On Wed, Oct 30, 2019 at 04:03:02PM +0100, Torsten Duwe wrote: > On Tue, Oct 29, 2019 at 04:58:26PM +0000, Mark Rutland wrote: > > When using patchable-function-entry, the compiler will record the > > callsites into a section named "__patchable_function_entries" rather > > than "__mcount_loc". Let's abstract this difference behind a new > > FTRACE_CALLSITE_SECTION, so that architectures don't have to handle this > > explicitly (e.g. with custom module linker scripts). > > > > As parisc currently handles this explicitly, it is fixed up accordingly, > > with its custom linker script removed. Since FTRACE_CALLSITE_SECTION is > > only defined when DYNAMIC_FTRACE is selected, the parisc module loading > > code is updated to only use the definition in that case. When > > DYNAMIC_FTRACE is not selected, modules shouldn't have this section, so > > this removes some redundant work in that case. > > > > I built parisc generic-{32,64}bit_defconfig with DYNAMIC_FTRACE enabled, > > and verified that the section made it into the .ko files for modules. > > This is because of remaining #ifdeffery in include/asm-generic/vmlinux.lds.h: > > #ifdef CC_USING_PATCHABLE_FUNCTION_ENTRY > #define MCOUNT_REC() . = ALIGN(8); \ > __start_mcount_loc = .; \ > KEEP(*(__patchable_function_entries)) \ > __stop_mcount_loc = .; > #else > #define MCOUNT_REC() . = ALIGN(8); \ > __start_mcount_loc = .; \ > KEEP(*(__mcount_loc)) \ > __stop_mcount_loc = .; > #endif For modules we use a combination of scripts/module-common.lds and an architecture's own module.lds, not vmlinux.lds.h. So I don't think the above is relevant for modules. For modules the kernel's ELF loader looks for the ELF ection, not the __{start,stop}_mcount_loc symbols that we use for the main kernel image. FWIW, when building a module, I see the following linker operations: | [mark@blommer:~/src/linux]% toolchain korg gcc-8.1.0-nolibc make V=1 ARCH=arm64 CROSS_COMPILE=aarch64-linux- arch/arm64/crypto/sha512-ce.ko | grep aarch64-linux-ld | aarch64-linux-ld -EL -maarch64elf -r -o arch/arm64/crypto/sha512-ce.o arch/arm64/crypto/sha512-ce-glue.o arch/arm64/crypto/sha512-ce-core.o | aarch64-linux-ld -r -EL -maarch64elf --build-id -T ./scripts/module-common.lds -T ./arch/arm64/kernel/module.lds -o arch/arm64/crypto/sha512-ce.ko arch/arm64/crypto/sha512-ce.o arch/arm64/crypto/sha512-ce.mod.o; true > Maybe you want to tackle that as well? I suggest to have at least one > FTRACE_CALLSITE_SECTION definition without double quotes. Alternatively, my > earlier solution just kept both sections, in case either one or both are > present. > > KEEP(*(__patchable_function_entries)) \ > KEEP(*(__mcount_loc)) \ I agree that the CC_USING_PATCHABLE_FUNCTION_ENTRY ifdeffery could be simplified, and that it would be nice to consistently use FTRACE_CALLSITE_SECTION if we can. However, the generic linker script doesn't include anything, and I don't see a good location for that to live. What I could do is add an explicit comment: /* * The ftrace call sites are logged to a section whose name depends on the * compiler option used. A given kernel image will only use one, AKA * FTRACE_CALLSITE_SECTION. We capture all of them here to avoid header * dependencies. */ #define MCOUNT_REC() \ . = ALIGN(8); \ __start_mcount_loc = .; \ KEEP(*(__patchable_function_entries)) \ KEEP(*(__mcount_loc)) \ __stop_mcount_loc = .; ... which should make the dependency clear. Does that sound good to you? Thanks, Mark.